30 lines
844 B
Diff
30 lines
844 B
Diff
From 9c9051d1c00164cf2b63e23ad10f24ddce2b0413 Mon Sep 17 00:00:00 2001
|
|
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
|
Date: Sat, 21 Sep 2013 15:53:17 +0200
|
|
Subject: [PATCH] rostest is optional
|
|
|
|
---
|
|
chatter_sender/CMakeLists.txt | 6 +++++-
|
|
1 file changed, 5 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/chatter_sender/CMakeLists.txt b/chatter_sender/CMakeLists.txt
|
|
index f2bc563..243bc53 100644
|
|
--- a/chatter_sender/CMakeLists.txt
|
|
+++ b/chatter_sender/CMakeLists.txt
|
|
@@ -1,7 +1,11 @@
|
|
cmake_minimum_required(VERSION 2.8.3)
|
|
project(chatter_sender)
|
|
|
|
-find_package(catkin REQUIRED COMPONENTS chatter_msgs roscpp rostest)
|
|
+if(CATKIN_ENABLE_TESTING)
|
|
+ find_package(catkin REQUIRED COMPONENTS chatter_msgs roscpp rostest)
|
|
+else()
|
|
+ find_package(catkin REQUIRED COMPONENTS chatter_msgs roscpp)
|
|
+endif()
|
|
|
|
catkin_package()
|
|
|
|
--
|
|
1.7.10.4
|
|
|