meta-ros/recipes-ros/audio-common/sound-play/0002-sound_play-Fix-build-w...

36 lines
1.0 KiB
Diff

From ecdde483c81fb89e35f025ee3aacba7cd45528ab Mon Sep 17 00:00:00 2001
From: Alexis Ballier <aballier@gentoo.org>
Date: Fri, 4 Dec 2015 12:38:42 +0100
Subject: [PATCH 2/2] sound_play: Fix build with -DCATKIN_ENABLE_TESTING=OFF.
https://bugs.gentoo.org/show_bug.cgi?id=567466
Upstream-Status: Backport [commit ecdde483c81fb89e35f025ee3aacba7cd45528ab]
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
---
sound_play/CMakeLists.txt | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/sound_play/CMakeLists.txt b/sound_play/CMakeLists.txt
index ada0b07..3f9604c 100644
--- a/sound_play/CMakeLists.txt
+++ b/sound_play/CMakeLists.txt
@@ -16,9 +16,11 @@ generate_messages(DEPENDENCIES actionlib_msgs)
catkin_package(CATKIN_DEPENDS message_runtime actionlib_msgs
INCLUDE_DIRS include)
-catkin_add_nosetests(scripts/test)
+if(CATKIN_ENABLE_TESTING)
+ catkin_add_nosetests(scripts/test)
-add_subdirectory(test)
+ add_subdirectory(test)
+endif()
install(PROGRAMS
scripts/playbuiltin.py
--
2.4.3