forked from openkylin/astroid
50 lines
2.0 KiB
Plaintext
50 lines
2.0 KiB
Plaintext
Source: astroid
|
|
Section: python
|
|
Priority: optional
|
|
Maintainer: OpenKylin Developers <packaging@lists.openkylin.top>
|
|
Build-Depends: debhelper-compat (= 13),
|
|
dh-python,
|
|
python3-all,
|
|
python3-lazy-object-proxy (>= 1.4.0),
|
|
python3-pytest <!nocheck>,
|
|
python3-pytest-runner <!nocheck>,
|
|
python3-setuptools,
|
|
python3-typing-extensions (>= 3.10.0) <!nocheck>,
|
|
python3-wrapt,
|
|
Standards-Version: 4.6.0.1
|
|
Homepage: https://github.com/PyCQA/astroid
|
|
Vcs-Git: https://gitee.com/openkylin/astroid.git
|
|
Vcs-Browser: https://gitee.com/openkylin/astroid
|
|
|
|
Package: python3-astroid
|
|
Architecture: all
|
|
Depends: python3-setuptools,
|
|
python3-six,
|
|
python3-typing-extensions,
|
|
${misc:Depends},
|
|
${python3:Depends},
|
|
Description: rebuild a new abstract syntax tree from Python's AST (Python3)
|
|
The aim of this module is to provide a common base representation of
|
|
Python source code for projects such as pychecker, pyreverse,
|
|
pylint... Well, actually the development of this library is essentially
|
|
governed by pylint's needs. It used to be called logilab-astng.
|
|
.
|
|
It provides a compatible representation which comes from the `_ast`
|
|
module. It rebuilds the tree generated by the builtin _ast module by
|
|
recursively walking down the AST and building an extended ast. The new
|
|
node classes have additional methods and attributes for different
|
|
usages. They include some support for static inference and local name
|
|
scopes. Furthermore, astroid builds partial trees by inspecting living
|
|
objects.
|
|
.
|
|
Main modules are:
|
|
.
|
|
* `bases`, `node_classses` and `scoped_nodes` contain the classes for the
|
|
different type of nodes of the tree.
|
|
.
|
|
* the `manager` contains a high level object to get astroid trees from
|
|
source files and living objects. It maintains a cache of previously
|
|
constructed tree for quick access.
|
|
.
|
|
python3-astroid is the new name of former python3-logilab-astng library.
|