poetry-core/debian/copyright

838 lines
50 KiB
Plaintext

Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: poetry-core
Source: <url://example.com>
#
# Please double check copyright with the licensecheck(1) command.
Files: .flake8
.gitattributes
.github/ISSUE_TEMPLATE/config.yml
.github/PULL_REQUEST_TEMPLATE.md
.github/workflows/downstream.yml
.github/workflows/integration.yml
.github/workflows/release.yml
.github/workflows/tests.yml
.gitignore
.pre-commit-config.yaml
CHANGELOG.md
Makefile
README.md
poetry.lock
pyproject.toml
src/poetry/core/__init__.py
src/poetry/core/_vendor/_pyrsistent_version.py
src/poetry/core/_vendor/attr/__init__.py
src/poetry/core/_vendor/attr/_cmp.py
src/poetry/core/_vendor/attr/_compat.py
src/poetry/core/_vendor/attr/_config.py
src/poetry/core/_vendor/attr/_funcs.py
src/poetry/core/_vendor/attr/_make.py
src/poetry/core/_vendor/attr/_next_gen.py
src/poetry/core/_vendor/attr/_version_info.py
src/poetry/core/_vendor/attr/converters.py
src/poetry/core/_vendor/attr/exceptions.py
src/poetry/core/_vendor/attr/filters.py
src/poetry/core/_vendor/attr/py.typed
src/poetry/core/_vendor/attr/setters.py
src/poetry/core/_vendor/attr/validators.py
src/poetry/core/_vendor/attrs/__init__.py
src/poetry/core/_vendor/attrs/converters.py
src/poetry/core/_vendor/attrs/exceptions.py
src/poetry/core/_vendor/attrs/filters.py
src/poetry/core/_vendor/attrs/py.typed
src/poetry/core/_vendor/attrs/setters.py
src/poetry/core/_vendor/attrs/validators.py
src/poetry/core/_vendor/jsonschema/__init__.py
src/poetry/core/_vendor/jsonschema/__main__.py
src/poetry/core/_vendor/jsonschema/_format.py
src/poetry/core/_vendor/jsonschema/_legacy_validators.py
src/poetry/core/_vendor/jsonschema/_types.py
src/poetry/core/_vendor/jsonschema/_utils.py
src/poetry/core/_vendor/jsonschema/_validators.py
src/poetry/core/_vendor/jsonschema/benchmarks/__init__.py
src/poetry/core/_vendor/jsonschema/benchmarks/issue232.py
src/poetry/core/_vendor/jsonschema/benchmarks/issue232/issue.json
src/poetry/core/_vendor/jsonschema/benchmarks/json_schema_test_suite.py
src/poetry/core/_vendor/jsonschema/cli.py
src/poetry/core/_vendor/jsonschema/exceptions.py
src/poetry/core/_vendor/jsonschema/protocols.py
src/poetry/core/_vendor/jsonschema/schemas/draft2019-09.json
src/poetry/core/_vendor/jsonschema/schemas/draft2020-12.json
src/poetry/core/_vendor/jsonschema/schemas/draft3.json
src/poetry/core/_vendor/jsonschema/schemas/draft4.json
src/poetry/core/_vendor/jsonschema/schemas/draft6.json
src/poetry/core/_vendor/jsonschema/schemas/draft7.json
src/poetry/core/_vendor/jsonschema/schemas/vocabularies.json
src/poetry/core/_vendor/jsonschema/validators.py
src/poetry/core/_vendor/lark/__init__.py
src/poetry/core/_vendor/lark/__pyinstaller/__init__.py
src/poetry/core/_vendor/lark/ast_utils.py
src/poetry/core/_vendor/lark/common.py
src/poetry/core/_vendor/lark/exceptions.py
src/poetry/core/_vendor/lark/grammar.py
src/poetry/core/_vendor/lark/grammars/__init__.py
src/poetry/core/_vendor/lark/grammars/common.lark
src/poetry/core/_vendor/lark/grammars/lark.lark
src/poetry/core/_vendor/lark/grammars/python.lark
src/poetry/core/_vendor/lark/grammars/unicode.lark
src/poetry/core/_vendor/lark/indenter.py
src/poetry/core/_vendor/lark/lark.py
src/poetry/core/_vendor/lark/lexer.py
src/poetry/core/_vendor/lark/load_grammar.py
src/poetry/core/_vendor/lark/parse_tree_builder.py
src/poetry/core/_vendor/lark/parser_frontends.py
src/poetry/core/_vendor/lark/parsers/__init__.py
src/poetry/core/_vendor/lark/parsers/cyk.py
src/poetry/core/_vendor/lark/parsers/earley.py
src/poetry/core/_vendor/lark/parsers/earley_common.py
src/poetry/core/_vendor/lark/parsers/earley_forest.py
src/poetry/core/_vendor/lark/parsers/grammar_analysis.py
src/poetry/core/_vendor/lark/parsers/lalr_analysis.py
src/poetry/core/_vendor/lark/parsers/lalr_interactive_parser.py
src/poetry/core/_vendor/lark/parsers/lalr_parser.py
src/poetry/core/_vendor/lark/parsers/resolve_ambig.py
src/poetry/core/_vendor/lark/parsers/xearley.py
src/poetry/core/_vendor/lark/py.typed
src/poetry/core/_vendor/lark/reconstruct.py
src/poetry/core/_vendor/lark/tools/__init__.py
src/poetry/core/_vendor/lark/tools/nearley.py
src/poetry/core/_vendor/lark/tools/serialize.py
src/poetry/core/_vendor/lark/tree.py
src/poetry/core/_vendor/lark/tree_matcher.py
src/poetry/core/_vendor/lark/tree_templates.py
src/poetry/core/_vendor/lark/utils.py
src/poetry/core/_vendor/lark/visitors.py
src/poetry/core/_vendor/packaging/__about__.py
src/poetry/core/_vendor/packaging/__init__.py
src/poetry/core/_vendor/packaging/_manylinux.py
src/poetry/core/_vendor/packaging/_musllinux.py
src/poetry/core/_vendor/packaging/_structures.py
src/poetry/core/_vendor/packaging/markers.py
src/poetry/core/_vendor/packaging/py.typed
src/poetry/core/_vendor/packaging/requirements.py
src/poetry/core/_vendor/packaging/specifiers.py
src/poetry/core/_vendor/packaging/tags.py
src/poetry/core/_vendor/packaging/utils.py
src/poetry/core/_vendor/packaging/version.py
src/poetry/core/_vendor/pyparsing/actions.py
src/poetry/core/_vendor/pyparsing/common.py
src/poetry/core/_vendor/pyparsing/diagram/__init__.py
src/poetry/core/_vendor/pyparsing/exceptions.py
src/poetry/core/_vendor/pyparsing/helpers.py
src/poetry/core/_vendor/pyparsing/py.typed
src/poetry/core/_vendor/pyparsing/results.py
src/poetry/core/_vendor/pyparsing/testing.py
src/poetry/core/_vendor/pyparsing/unicode.py
src/poetry/core/_vendor/pyparsing/util.py
src/poetry/core/_vendor/pyrsistent/__init__.py
src/poetry/core/_vendor/pyrsistent/_checked_types.py
src/poetry/core/_vendor/pyrsistent/_field_common.py
src/poetry/core/_vendor/pyrsistent/_helpers.py
src/poetry/core/_vendor/pyrsistent/_immutable.py
src/poetry/core/_vendor/pyrsistent/_pbag.py
src/poetry/core/_vendor/pyrsistent/_pclass.py
src/poetry/core/_vendor/pyrsistent/_pdeque.py
src/poetry/core/_vendor/pyrsistent/_plist.py
src/poetry/core/_vendor/pyrsistent/_pmap.py
src/poetry/core/_vendor/pyrsistent/_precord.py
src/poetry/core/_vendor/pyrsistent/_pset.py
src/poetry/core/_vendor/pyrsistent/_pvector.py
src/poetry/core/_vendor/pyrsistent/_transformations.py
src/poetry/core/_vendor/pyrsistent/py.typed
src/poetry/core/_vendor/pyrsistent/typing.py
src/poetry/core/_vendor/tomlkit/__init__.py
src/poetry/core/_vendor/tomlkit/_compat.py
src/poetry/core/_vendor/tomlkit/_utils.py
src/poetry/core/_vendor/tomlkit/api.py
src/poetry/core/_vendor/tomlkit/container.py
src/poetry/core/_vendor/tomlkit/exceptions.py
src/poetry/core/_vendor/tomlkit/items.py
src/poetry/core/_vendor/tomlkit/parser.py
src/poetry/core/_vendor/tomlkit/py.typed
src/poetry/core/_vendor/tomlkit/source.py
src/poetry/core/_vendor/tomlkit/toml_char.py
src/poetry/core/_vendor/tomlkit/toml_document.py
src/poetry/core/_vendor/tomlkit/toml_file.py
src/poetry/core/_vendor/typing_extensions.py
src/poetry/core/_vendor/vendor.txt
src/poetry/core/constraints/__init__.py
src/poetry/core/constraints/generic/__init__.py
src/poetry/core/constraints/generic/any_constraint.py
src/poetry/core/constraints/generic/base_constraint.py
src/poetry/core/constraints/generic/constraint.py
src/poetry/core/constraints/generic/empty_constraint.py
src/poetry/core/constraints/generic/multi_constraint.py
src/poetry/core/constraints/generic/parser.py
src/poetry/core/constraints/generic/union_constraint.py
src/poetry/core/constraints/version/__init__.py
src/poetry/core/constraints/version/empty_constraint.py
src/poetry/core/constraints/version/exceptions.py
src/poetry/core/constraints/version/parser.py
src/poetry/core/constraints/version/patterns.py
src/poetry/core/constraints/version/util.py
src/poetry/core/constraints/version/version.py
src/poetry/core/constraints/version/version_constraint.py
src/poetry/core/constraints/version/version_range.py
src/poetry/core/constraints/version/version_range_constraint.py
src/poetry/core/constraints/version/version_union.py
src/poetry/core/exceptions/__init__.py
src/poetry/core/exceptions/base.py
src/poetry/core/factory.py
src/poetry/core/json/__init__.py
src/poetry/core/json/schemas/poetry-schema.json
src/poetry/core/masonry/__init__.py
src/poetry/core/masonry/api.py
src/poetry/core/masonry/builder.py
src/poetry/core/masonry/builders/__init__.py
src/poetry/core/masonry/builders/builder.py
src/poetry/core/masonry/builders/sdist.py
src/poetry/core/masonry/builders/wheel.py
src/poetry/core/masonry/metadata.py
src/poetry/core/masonry/utils/__init__.py
src/poetry/core/masonry/utils/helpers.py
src/poetry/core/masonry/utils/include.py
src/poetry/core/masonry/utils/module.py
src/poetry/core/masonry/utils/package_include.py
src/poetry/core/packages/__init__.py
src/poetry/core/packages/constraints/__init__.py
src/poetry/core/packages/dependency.py
src/poetry/core/packages/dependency_group.py
src/poetry/core/packages/directory_dependency.py
src/poetry/core/packages/file_dependency.py
src/poetry/core/packages/package.py
src/poetry/core/packages/project_package.py
src/poetry/core/packages/specification.py
src/poetry/core/packages/url_dependency.py
src/poetry/core/packages/utils/__init__.py
src/poetry/core/packages/utils/link.py
src/poetry/core/packages/utils/utils.py
src/poetry/core/packages/vcs_dependency.py
src/poetry/core/poetry.py
src/poetry/core/py.typed
src/poetry/core/pyproject/__init__.py
src/poetry/core/pyproject/exceptions.py
src/poetry/core/pyproject/tables.py
src/poetry/core/pyproject/toml.py
src/poetry/core/semver/__init__.py
src/poetry/core/semver/empty_constraint.py
src/poetry/core/semver/exceptions.py
src/poetry/core/semver/helpers.py
src/poetry/core/semver/patterns.py
src/poetry/core/semver/util.py
src/poetry/core/semver/version.py
src/poetry/core/semver/version_constraint.py
src/poetry/core/semver/version_range.py
src/poetry/core/semver/version_range_constraint.py
src/poetry/core/semver/version_union.py
src/poetry/core/spdx/__init__.py
src/poetry/core/spdx/data/licenses.json
src/poetry/core/spdx/helpers.py
src/poetry/core/spdx/license.py
src/poetry/core/spdx/updater.py
src/poetry/core/toml/__init__.py
src/poetry/core/toml/exceptions.py
src/poetry/core/toml/file.py
src/poetry/core/utils/__init__.py
src/poetry/core/utils/_compat.py
src/poetry/core/utils/helpers.py
src/poetry/core/utils/patterns.py
src/poetry/core/utils/toml_file.py
src/poetry/core/vcs/__init__.py
src/poetry/core/vcs/git.py
src/poetry/core/version/__init__.py
src/poetry/core/version/exceptions.py
src/poetry/core/version/grammars/__init__.py
src/poetry/core/version/grammars/markers.lark
src/poetry/core/version/grammars/pep508.lark
src/poetry/core/version/helpers.py
src/poetry/core/version/markers.py
src/poetry/core/version/parser.py
src/poetry/core/version/pep440/__init__.py
src/poetry/core/version/pep440/parser.py
src/poetry/core/version/pep440/segments.py
src/poetry/core/version/pep440/version.py
src/poetry/core/version/requirements.py
tests/__init__.py
tests/conftest.py
tests/constraints/__init__.py
tests/constraints/generic/__init__.py
tests/constraints/generic/test_constraint.py
tests/constraints/generic/test_main.py
tests/constraints/generic/test_multi_constraint.py
tests/constraints/generic/test_union_constraint.py
tests/constraints/version/__init__.py
tests/constraints/version/test_helpers.py
tests/constraints/version/test_parse_constraint.py
tests/constraints/version/test_utils.py
tests/constraints/version/test_version.py
tests/constraints/version/test_version_constraint.py
tests/constraints/version/test_version_range.py
tests/fixtures/complete.toml
tests/fixtures/distributions/demo-0.1.0-py2.py3-none-any.whl
tests/fixtures/distributions/demo-0.1.0.tar.gz
tests/fixtures/invalid_pyproject/pyproject.toml
tests/fixtures/pep_517_backend/README.md
tests/fixtures/pep_517_backend/foo/__init__.py
tests/fixtures/pep_517_backend/pyproject.toml
tests/fixtures/project_failing_strict_validation/pyproject.toml
tests/fixtures/project_with_build_system_requires/pyproject.toml
tests/fixtures/project_with_groups_and_explicit_main/README.rst
tests/fixtures/project_with_groups_and_explicit_main/simple_project/__init__.py
tests/fixtures/project_with_groups_and_legacy_dev/README.rst
tests/fixtures/project_with_groups_and_legacy_dev/simple_project/__init__.py
tests/fixtures/project_with_invalid_dev_deps/pyproject.toml
tests/fixtures/project_with_markers_and_extras/project/__init__.py
tests/fixtures/project_with_markers_and_extras/pyproject.toml
tests/fixtures/project_with_multi_constraints_dependency/project/__init__.py
tests/fixtures/project_with_multi_constraints_dependency/pyproject.toml
tests/fixtures/project_with_pep517_non_poetry/pyproject.toml
tests/fixtures/project_with_setup/my_package/__init__.py
tests/fixtures/project_with_setup/setup.py
tests/fixtures/project_with_setup_cfg_only/setup.cfg
tests/fixtures/sample_project/README.rst
tests/fixtures/sample_project/pyproject.toml
tests/fixtures/script-files/sample_script.py
tests/fixtures/script-files/sample_script.sh
tests/fixtures/simple_project/README.rst
tests/fixtures/simple_project/dist/simple_project-1.2.3-py2.py3-none-any.whl
tests/fixtures/simple_project/dist/simple_project-1.2.3.tar.gz
tests/fixtures/simple_project/pyproject.toml
tests/fixtures/simple_project/simple_project/__init__.py
tests/fixtures/with_readme_files/README-1.rst
tests/fixtures/with_readme_files/README-2.rst
tests/fixtures/with_readme_files/pyproject.toml
tests/fixtures/with_readme_files/single_python.py
tests/integration/__init__.py
tests/integration/test_pep517.py
tests/integration/test_pep517_backend.py
tests/json/__init__.py
tests/json/test_poetry_schema.py
tests/masonry/__init__.py
tests/masonry/builders/__init__.py
tests/masonry/builders/fixtures/build_script_in_subdir/pyproject.toml
tests/masonry/builders/fixtures/build_script_in_subdir/scripts/build.py
tests/masonry/builders/fixtures/build_script_in_subdir/src/foo.py
tests/masonry/builders/fixtures/case_sensitive_exclusions/README.rst
tests/masonry/builders/fixtures/case_sensitive_exclusions/my_package/Foo/Bar.py
tests/masonry/builders/fixtures/case_sensitive_exclusions/my_package/Foo/IncludedBar.py
tests/masonry/builders/fixtures/case_sensitive_exclusions/my_package/Foo/SecondBar.py
tests/masonry/builders/fixtures/case_sensitive_exclusions/my_package/Foo/lowercasebar.py
tests/masonry/builders/fixtures/case_sensitive_exclusions/my_package/FooBar/Bar.py
tests/masonry/builders/fixtures/case_sensitive_exclusions/my_package/FooBar/lowercasebar.py
tests/masonry/builders/fixtures/case_sensitive_exclusions/my_package/__init__.py
tests/masonry/builders/fixtures/case_sensitive_exclusions/my_package/bar/CapitalFoo.py
tests/masonry/builders/fixtures/case_sensitive_exclusions/my_package/bar/foo.py
tests/masonry/builders/fixtures/case_sensitive_exclusions/pyproject.toml
tests/masonry/builders/fixtures/comma_file/comma_file/__init__.py
tests/masonry/builders/fixtures/comma_file/comma_file/a,b.py
tests/masonry/builders/fixtures/comma_file/pyproject.toml
tests/masonry/builders/fixtures/complete/README.rst
tests/masonry/builders/fixtures/complete/bin/script.sh
tests/masonry/builders/fixtures/complete/my_package/__init__.py
tests/masonry/builders/fixtures/complete/my_package/data1/test.json
tests/masonry/builders/fixtures/complete/my_package/sub_pkg1/__init__.py
tests/masonry/builders/fixtures/complete/my_package/sub_pkg1/extra_file.xml
tests/masonry/builders/fixtures/complete/my_package/sub_pkg2/__init__.py
tests/masonry/builders/fixtures/complete/my_package/sub_pkg2/data2/data.json
tests/masonry/builders/fixtures/complete/my_package/sub_pkg3/foo.py
tests/masonry/builders/fixtures/complete/pyproject.toml
tests/masonry/builders/fixtures/default_src_with_excluded_data/README.rst
tests/masonry/builders/fixtures/default_src_with_excluded_data/pyproject.toml
tests/masonry/builders/fixtures/default_src_with_excluded_data/src/my_package/__init__.py
tests/masonry/builders/fixtures/default_src_with_excluded_data/src/my_package/data/data1.txt
tests/masonry/builders/fixtures/default_src_with_excluded_data/src/my_package/data/sub_data/data2.txt
tests/masonry/builders/fixtures/default_src_with_excluded_data/src/my_package/data/sub_data/data3.txt
tests/masonry/builders/fixtures/default_with_excluded_data/README.rst
tests/masonry/builders/fixtures/default_with_excluded_data/my_package/__init__.py
tests/masonry/builders/fixtures/default_with_excluded_data/my_package/data/data1.txt
tests/masonry/builders/fixtures/default_with_excluded_data/my_package/data/sub_data/data2.txt
tests/masonry/builders/fixtures/default_with_excluded_data/my_package/data/sub_data/data3.txt
tests/masonry/builders/fixtures/default_with_excluded_data/pyproject.toml
tests/masonry/builders/fixtures/default_with_excluded_data_toml/README.rst
tests/masonry/builders/fixtures/default_with_excluded_data_toml/my_package/__init__.py
tests/masonry/builders/fixtures/default_with_excluded_data_toml/my_package/data/data1.txt
tests/masonry/builders/fixtures/default_with_excluded_data_toml/my_package/data/sub_data/data2.txt
tests/masonry/builders/fixtures/default_with_excluded_data_toml/my_package/data/sub_data/data3.txt
tests/masonry/builders/fixtures/default_with_excluded_data_toml/pyproject.toml
tests/masonry/builders/fixtures/disable_setup_py/README.rst
tests/masonry/builders/fixtures/disable_setup_py/my_package/__init__.py
tests/masonry/builders/fixtures/disable_setup_py/pyproject.toml
tests/masonry/builders/fixtures/epoch/README.rst
tests/masonry/builders/fixtures/epoch/epoch.py
tests/masonry/builders/fixtures/epoch/pyproject.toml
tests/masonry/builders/fixtures/exclude-whl-include-sdist/exclude_whl_include_sdist/__init__.py
tests/masonry/builders/fixtures/exclude-whl-include-sdist/exclude_whl_include_sdist/compiled/source.c
tests/masonry/builders/fixtures/exclude-whl-include-sdist/exclude_whl_include_sdist/compiled/source.h
tests/masonry/builders/fixtures/exclude-whl-include-sdist/exclude_whl_include_sdist/cython_code.pyx
tests/masonry/builders/fixtures/exclude-whl-include-sdist/pyproject.toml
tests/masonry/builders/fixtures/exclude_nested_data_toml/README.rst
tests/masonry/builders/fixtures/exclude_nested_data_toml/my_package/__init__.py
tests/masonry/builders/fixtures/exclude_nested_data_toml/my_package/data/data1.txt
tests/masonry/builders/fixtures/exclude_nested_data_toml/my_package/data/data2.txt
tests/masonry/builders/fixtures/exclude_nested_data_toml/my_package/data/sub_data/data2.txt
tests/masonry/builders/fixtures/exclude_nested_data_toml/my_package/data/sub_data/data3.txt
tests/masonry/builders/fixtures/exclude_nested_data_toml/my_package/puplic/item1/itemdata1.txt
tests/masonry/builders/fixtures/exclude_nested_data_toml/my_package/puplic/item1/subitem/subitemdata.txt
tests/masonry/builders/fixtures/exclude_nested_data_toml/my_package/puplic/item2/itemdata2.txt
tests/masonry/builders/fixtures/exclude_nested_data_toml/my_package/puplic/publicdata.txt
tests/masonry/builders/fixtures/exclude_nested_data_toml/pyproject.toml
tests/masonry/builders/fixtures/excluded_subpackage/README.rst
tests/masonry/builders/fixtures/excluded_subpackage/example/__init__.py
tests/masonry/builders/fixtures/excluded_subpackage/example/test/__init__.py
tests/masonry/builders/fixtures/excluded_subpackage/example/test/excluded.py
tests/masonry/builders/fixtures/excluded_subpackage/pyproject.toml
tests/masonry/builders/fixtures/extended/README.rst
tests/masonry/builders/fixtures/extended/build.py
tests/masonry/builders/fixtures/extended/extended/__init__.py
tests/masonry/builders/fixtures/extended/extended/extended.c
tests/masonry/builders/fixtures/extended/pyproject.toml
tests/masonry/builders/fixtures/extended/setup.py
tests/masonry/builders/fixtures/extended_with_no_setup/README.rst
tests/masonry/builders/fixtures/extended_with_no_setup/build.py
tests/masonry/builders/fixtures/extended_with_no_setup/extended/__init__.py
tests/masonry/builders/fixtures/extended_with_no_setup/extended/extended.c
tests/masonry/builders/fixtures/extended_with_no_setup/pyproject.toml
tests/masonry/builders/fixtures/include_excluded_code/lib/my_package/__init__.py
tests/masonry/builders/fixtures/include_excluded_code/lib/my_package/generated.py
tests/masonry/builders/fixtures/include_excluded_code/pyproject.toml
tests/masonry/builders/fixtures/invalid_case_sensitive_exclusions/README.rst
tests/masonry/builders/fixtures/invalid_case_sensitive_exclusions/my_package/Bar/foo/bar/Foo.py
tests/masonry/builders/fixtures/invalid_case_sensitive_exclusions/my_package/Foo/Bar.py
tests/masonry/builders/fixtures/invalid_case_sensitive_exclusions/my_package/Foo/IncludedBar.py
tests/masonry/builders/fixtures/invalid_case_sensitive_exclusions/my_package/Foo/SecondBar.py
tests/masonry/builders/fixtures/invalid_case_sensitive_exclusions/my_package/Foo/lowercasebar.py
tests/masonry/builders/fixtures/invalid_case_sensitive_exclusions/my_package/FooBar/Bar.py
tests/masonry/builders/fixtures/invalid_case_sensitive_exclusions/my_package/FooBar/lowercasebar.py
tests/masonry/builders/fixtures/invalid_case_sensitive_exclusions/my_package/__init__.py
tests/masonry/builders/fixtures/invalid_case_sensitive_exclusions/pyproject.toml
tests/masonry/builders/fixtures/licenses_and_copying/COPYING.txt
tests/masonry/builders/fixtures/licenses_and_copying/LICENSE.md
tests/masonry/builders/fixtures/licenses_and_copying/LICENSES/BSD-3.md
tests/masonry/builders/fixtures/licenses_and_copying/LICENSES/CUSTOM-LICENSE
tests/masonry/builders/fixtures/licenses_and_copying/LICENSES/MIT.txt
tests/masonry/builders/fixtures/licenses_and_copying/README.rst
tests/masonry/builders/fixtures/licenses_and_copying/my_package/__init__.py
tests/masonry/builders/fixtures/licenses_and_copying/pyproject.toml
tests/masonry/builders/fixtures/localversionlabel/localversionlabel.py
tests/masonry/builders/fixtures/localversionlabel/pyproject.toml
tests/masonry/builders/fixtures/module1/README.rst
tests/masonry/builders/fixtures/module1/module1.py
tests/masonry/builders/fixtures/module1/pyproject.toml
tests/masonry/builders/fixtures/pep_561_stub_only/pkg-stubs/__init__.pyi
tests/masonry/builders/fixtures/pep_561_stub_only/pkg-stubs/module.pyi
tests/masonry/builders/fixtures/pep_561_stub_only/pkg-stubs/subpkg/__init__.pyi
tests/masonry/builders/fixtures/pep_561_stub_only/pyproject.toml
tests/masonry/builders/fixtures/pep_561_stub_only_partial/pkg-stubs/__init__.pyi
tests/masonry/builders/fixtures/pep_561_stub_only_partial/pkg-stubs/module.pyi
tests/masonry/builders/fixtures/pep_561_stub_only_partial/pkg-stubs/py.typed
tests/masonry/builders/fixtures/pep_561_stub_only_partial/pkg-stubs/subpkg/__init__.pyi
tests/masonry/builders/fixtures/pep_561_stub_only_partial/pyproject.toml
tests/masonry/builders/fixtures/pep_561_stub_only_partial_namespace/pkg-stubs/module.pyi
tests/masonry/builders/fixtures/pep_561_stub_only_partial_namespace/pkg-stubs/subpkg/__init__.pyi
tests/masonry/builders/fixtures/pep_561_stub_only_partial_namespace/pkg-stubs/subpkg/py.typed
tests/masonry/builders/fixtures/pep_561_stub_only_partial_namespace/pyproject.toml
tests/masonry/builders/fixtures/pep_561_stub_only_src/pyproject.toml
tests/masonry/builders/fixtures/pep_561_stub_only_src/src/pkg-stubs/__init__.pyi
tests/masonry/builders/fixtures/pep_561_stub_only_src/src/pkg-stubs/module.pyi
tests/masonry/builders/fixtures/pep_561_stub_only_src/src/pkg-stubs/subpkg/__init__.pyi
tests/masonry/builders/fixtures/prerelease/README.rst
tests/masonry/builders/fixtures/prerelease/prerelease.py
tests/masonry/builders/fixtures/prerelease/pyproject.toml
tests/masonry/builders/fixtures/script_callable_legacy_string/README.rst
tests/masonry/builders/fixtures/script_callable_legacy_string/my_package/__init__.py
tests/masonry/builders/fixtures/script_callable_legacy_string/pyproject.toml
tests/masonry/builders/fixtures/script_callable_legacy_table/README.rst
tests/masonry/builders/fixtures/script_callable_legacy_table/my_package/__init__.py
tests/masonry/builders/fixtures/script_callable_legacy_table/pyproject.toml
tests/masonry/builders/fixtures/script_reference_console/README.rst
tests/masonry/builders/fixtures/script_reference_console/my_package/__init__.py
tests/masonry/builders/fixtures/script_reference_console/pyproject.toml
tests/masonry/builders/fixtures/script_reference_file/README.rst
tests/masonry/builders/fixtures/script_reference_file/bin/script.sh
tests/masonry/builders/fixtures/script_reference_file/my_package/__init__.py
tests/masonry/builders/fixtures/script_reference_file/pyproject.toml
tests/masonry/builders/fixtures/script_reference_file_invalid_definition/README.rst
tests/masonry/builders/fixtures/script_reference_file_invalid_definition/bin/script.sh
tests/masonry/builders/fixtures/script_reference_file_invalid_definition/my_package/__init__.py
tests/masonry/builders/fixtures/script_reference_file_invalid_definition/pyproject.toml
tests/masonry/builders/fixtures/script_reference_file_missing/README.rst
tests/masonry/builders/fixtures/script_reference_file_missing/my_package/__init__.py
tests/masonry/builders/fixtures/script_reference_file_missing/pyproject.toml
tests/masonry/builders/fixtures/simple_version/README.rst
tests/masonry/builders/fixtures/simple_version/pyproject.toml
tests/masonry/builders/fixtures/simple_version/simple_version.py
tests/masonry/builders/fixtures/single_python/README.rst
tests/masonry/builders/fixtures/single_python/pyproject.toml
tests/masonry/builders/fixtures/single_python/single_python.py
tests/masonry/builders/fixtures/source_file/README.rst
tests/masonry/builders/fixtures/source_file/pyproject.toml
tests/masonry/builders/fixtures/source_file/src/module_src.py
tests/masonry/builders/fixtures/source_package/README.rst
tests/masonry/builders/fixtures/source_package/pyproject.toml
tests/masonry/builders/fixtures/source_package/src/package_src/__init__.py
tests/masonry/builders/fixtures/source_package/src/package_src/module.py
tests/masonry/builders/fixtures/split_source/lib_a/module_a/__init__.py
tests/masonry/builders/fixtures/split_source/lib_b/module_b/__init__.py
tests/masonry/builders/fixtures/split_source/pyproject.toml
tests/masonry/builders/fixtures/src_extended/README.rst
tests/masonry/builders/fixtures/src_extended/build.py
tests/masonry/builders/fixtures/src_extended/pyproject.toml
tests/masonry/builders/fixtures/src_extended/setup.py
tests/masonry/builders/fixtures/src_extended/src/extended/__init__.py
tests/masonry/builders/fixtures/src_extended/src/extended/extended.c
tests/masonry/builders/fixtures/with-include/README.rst
tests/masonry/builders/fixtures/with-include/extra_dir/README.md
tests/masonry/builders/fixtures/with-include/extra_dir/__init__.py
tests/masonry/builders/fixtures/with-include/extra_dir/sub_pkg/__init__.py
tests/masonry/builders/fixtures/with-include/extra_dir/sub_pkg/vcs_excluded.txt
tests/masonry/builders/fixtures/with-include/extra_dir/vcs_excluded.txt
tests/masonry/builders/fixtures/with-include/for_wheel_only/__init__.py
tests/masonry/builders/fixtures/with-include/my_module.py
tests/masonry/builders/fixtures/with-include/notes.txt
tests/masonry/builders/fixtures/with-include/package_with_include/__init__.py
tests/masonry/builders/fixtures/with-include/pyproject.toml
tests/masonry/builders/fixtures/with-include/src/src_package/__init__.py
tests/masonry/builders/fixtures/with-include/tests/__init__.py
tests/masonry/builders/fixtures/with_bad_path_dep/with_bad_path_dep/__init__.py
tests/masonry/builders/fixtures/with_bad_path_dev_dep/with_bad_path_dev_dep/__init__.py
tests/masonry/builders/fixtures/with_include_inline_table/both.txt
tests/masonry/builders/fixtures/with_include_inline_table/pyproject.toml
tests/masonry/builders/fixtures/with_include_inline_table/src/src_package/__init__.py
tests/masonry/builders/fixtures/with_include_inline_table/tests/__init__.py
tests/masonry/builders/fixtures/with_include_inline_table/tests/test_foo/test.py
tests/masonry/builders/fixtures/with_include_inline_table/wheel_only.txt
tests/masonry/builders/fixtures/with_url_dependency/pyproject.toml
tests/masonry/builders/fixtures/with_url_dependency/with_url_dependency/__init__.py
tests/masonry/builders/fixtures/with_vcs_dependency/pyproject.toml
tests/masonry/builders/fixtures/with_vcs_dependency/with_vcs_dependency/__init__.py
tests/masonry/builders/fixtures/with_wildcard_dependency_constraint/my_package/__init__.py
tests/masonry/builders/test_builder.py
tests/masonry/builders/test_complete.py
tests/masonry/builders/test_sdist.py
tests/masonry/builders/test_wheel.py
tests/masonry/test_api.py
tests/masonry/utils/__init__.py
tests/masonry/utils/fixtures/pep_561_stub_only/bad/__init__.pyi
tests/masonry/utils/fixtures/pep_561_stub_only/bad/module.pyi
tests/masonry/utils/fixtures/pep_561_stub_only/good-stubs/__init__.pyi
tests/masonry/utils/fixtures/pep_561_stub_only/good-stubs/module.pyi
tests/masonry/utils/fixtures/pep_561_stub_only_partial_namespace/good-stubs/module.pyi
tests/masonry/utils/fixtures/pep_561_stub_only_partial_namespace/good-stubs/subpkg/__init__.pyi
tests/masonry/utils/fixtures/pep_561_stub_only_partial_namespace/good-stubs/subpkg/py.typed
tests/masonry/utils/fixtures/with_includes/__init__.py
tests/masonry/utils/fixtures/with_includes/bar/baz.py
tests/masonry/utils/fixtures/with_includes/extra_package/some_dir/foo.py
tests/masonry/utils/fixtures/with_includes/extra_package/some_dir/quux.py
tests/masonry/utils/fixtures/with_includes/not_a_python_pkg/baz.txt
tests/masonry/utils/test_helpers.py
tests/masonry/utils/test_package_include.py
tests/packages/__init__.py
tests/packages/test_dependency.py
tests/packages/test_dependency_group.py
tests/packages/test_directory_dependency.py
tests/packages/test_file_dependency.py
tests/packages/test_main.py
tests/packages/test_package.py
tests/packages/test_specification.py
tests/packages/test_url_dependency.py
tests/packages/test_vcs_dependency.py
tests/packages/utils/__init__.py
tests/packages/utils/test_utils.py
tests/packages/utils/test_utils_link.py
tests/packages/utils/test_utils_urls.py
tests/pyproject/__init__.py
tests/pyproject/conftest.py
tests/pyproject/test_pyproject_toml.py
tests/pyproject/test_pyproject_toml_file.py
tests/spdx/__init__.py
tests/spdx/test_helpers.py
tests/spdx/test_license.py
tests/test_core_version.py
tests/test_factory.py
tests/testutils.py
tests/utils/__init__.py
tests/utils/test_helpers.py
tests/vcs/__init__.py
tests/vcs/test_vcs.py
tests/version/__init__.py
tests/version/pep440/__init__.py
tests/version/pep440/test_segments.py
tests/version/pep440/test_version.py
tests/version/test_markers.py
tests/version/test_requirements.py
tox.ini
vendors/patches/jsonschema.patch
vendors/poetry.lock
vendors/pyproject.toml
Copyright: __NO_COPYRIGHT_NOR_LICENSE__
License: __NO_COPYRIGHT_NOR_LICENSE__
Files: tests/fixtures/project_with_groups_and_explicit_main/pyproject.toml
tests/fixtures/project_with_groups_and_legacy_dev/pyproject.toml
tests/masonry/builders/fixtures/with_bad_path_dep/pyproject.toml
tests/masonry/builders/fixtures/with_bad_path_dev_dep/pyproject.toml
tests/masonry/builders/fixtures/with_wildcard_dependency_constraint/pyproject.toml
Copyright: __NO_COPYRIGHT__ in: tests/fixtures/project_with_groups_and_explicit_main/pyproject.toml
__NO_COPYRIGHT__ in: tests/fixtures/project_with_groups_and_legacy_dev/pyproject.toml
__NO_COPYRIGHT__ in: tests/masonry/builders/fixtures/with_bad_path_dep/pyproject.toml
__NO_COPYRIGHT__ in: tests/masonry/builders/fixtures/with_bad_path_dev_dep/pyproject.toml
__NO_COPYRIGHT__ in: tests/masonry/builders/fixtures/with_wildcard_dependency_constraint/pyproject.toml
License: __UNKNOWN__
[tool.poetry.dependencies]
Files: src/poetry/core/_vendor/pyparsing/__init__.py
src/poetry/core/_vendor/pyparsing/core.py
src/poetry/core/_vendor/pyrsistent/LICENSE.mit
Copyright: 2003-2022 Paul T. McGuire
2022 Tobias Gustafsson
License: Expat
Permission is hereby granted, free of charge, to any person
obtaining a copy of this software and associated documentation
files (the "Software"), to deal in the Software without
restriction, including without limitation the rights to use,
copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the
Software is furnished to do so, subject to the following
conditions:
.
The above copyright notice and this permission notice shall be
included in all copies or substantial portions of the Software.
.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
OTHER DEALINGS IN THE SOFTWARE.
Files: src/poetry/core/_vendor/typing_extensions.LICENSE
Copyright: 1991-1995 Stichting Mathematisch Centrum Amsterdam, The Netherlands.
License: ISC
Permission to use, copy, modify, and distribute this software and its
documentation for any purpose and without fee is hereby granted,
provided that the above copyright notice appear in all copies and that
both that copyright notice and this permission notice appear in
supporting documentation, and that the name of Stichting Mathematisch
Centrum or CWI not be used in advertising or publicity pertaining to
distribution of the software without specific, written prior
permission.
.
STICHTING MATHEMATISCH CENTRUM DISCLAIMS ALL WARRANTIES WITH REGARD TO
THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND
FITNESS, IN NO EVENT SHALL STICHTING MATHEMATISCH CENTRUM BE LIABLE
FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT
OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
Files: src/poetry/core/_vendor/lark/tools/standalone.py
Copyright: __NO_COPYRIGHT__ in: src/poetry/core/_vendor/lark/tools/standalone.py
License: __UNKNOWN__
>>> LICENSE
.
This tool and its generated code use a separate license from Lark,
and are subject to the terms of the Mozilla Public License, v. 2.0.
If a copy of the MPL was not distributed with this
file, You can obtain one at https://mozilla.org/MPL/2.0/.
.
If you wish to purchase a commercial license for this tool and its
generated code, you may contact me via email or otherwise.
.
If MPL2 is incompatible with your free or open-source project,
contact me and we'll work it out.
Files: src/poetry/core/_vendor/packaging/LICENSE.APACHE
Copyright: license to reproduce, prepare Derivative Works of, publicly display, publicly perform, sublicense, and distribute the Work and such Derivative Works in Source or Object form.
License: __UNKNOWN__
3. Grant of Patent License. Subject to the terms and conditions of
this License, each Contributor hereby grants to You a perpetual,
worldwide, non-exclusive, no-charge, royalty-free, irrevocable
(except as stated in this section) patent license to make, have made,
use, offer to sell, sell, import, and otherwise transfer the Work,
where such license applies only to those patent claims licensable
by such Contributor that are necessarily infringed by their
Contribution(s) alone or by combination of their Contribution(s)
with the Work to which such Contribution(s) was submitted. If You
institute patent litigation against any entity (including a
cross-claim or counterclaim in a lawsuit) alleging that the Work
or a Contribution incorporated within the Work constitutes direct
or contributory patent infringement, then any patent licenses
granted to You under this License for that Work shall terminate
as of the date such litigation is filed.
.
4. Redistribution. You may reproduce and distribute copies of the
Work or Derivative Works thereof in any medium, with or without
modifications, and in Source or Object form, provided that You
meet the following conditions:
.
(a) You must give any other recipients of the Work or
Derivative Works a copy of this License; and
.
(b) You must cause any modified files to carry prominent notices
stating that You changed the files; and
.
(d) If the Work includes a "NOTICE" text file as part of its
distribution, then any Derivative Works that You distribute must
include a readable copy of the attribution notices contained
within such NOTICE file, excluding those notices that do not
pertain to any part of the Derivative Works, in at least one
of the following places: within a NOTICE text file distributed
as part of the Derivative Works; within the Source form or
documentation, if provided along with the Derivative Works; or,
within a display generated by the Derivative Works, if and
wherever such third-party notices normally appear. The contents
of the NOTICE file are for informational purposes only and
do not modify the License. You may add Your own attribution
notices within Derivative Works that You distribute, alongside
or as an addendum to the NOTICE text from the Work, provided
that such additional attribution notices cannot be construed
as modifying the License.
.
You may add Your own copyright statement to Your modifications and
may provide additional or different license terms and conditions
for use, reproduction, or distribution of Your modifications, or
for any such Derivative Works as a whole, provided Your use,
reproduction, and distribution of the Work otherwise complies with
the conditions stated in this License.
.
5. Submission of Contributions. Unless You explicitly state otherwise,
any Contribution intentionally submitted for inclusion in the Work
by You to the Licensor shall be under the terms and conditions of
this License, without any additional terms or conditions.
Notwithstanding the above, nothing herein shall supersede or modify
the terms of any separate license agreement you may have executed
with Licensor regarding such Contributions.
.
6. Trademarks. This License does not grant permission to use the trade
names, trademarks, service marks, or product names of the Licensor,
except as required for reasonable and customary use in describing the
origin of the Work and reproducing the content of the NOTICE file.
.
7. Disclaimer of Warranty. Unless required by applicable law or
agreed to in writing, Licensor provides the Work (and each
Contributor provides its Contributions) on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
implied, including, without limitation, any warranties or conditions
of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
PARTICULAR PURPOSE. You are solely responsible for determining the
appropriateness of using or redistributing the Work and assume any
risks associated with Your exercise of permissions under this License.
.
8. Limitation of Liability. In no event and under no legal theory,
whether in tort (including negligence), contract, or otherwise,
unless required by applicable law (such as deliberate and grossly
negligent acts) or agreed to in writing, shall any Contributor be
liable to You for damages, including any direct, indirect, special,
incidental, or consequential damages of any character arising as a
result of this License or out of the use or inability to use the
Work (including but not limited to damages for loss of goodwill,
work stoppage, computer failure or malfunction, or any and all
other commercial damages or losses), even if such Contributor
has been advised of the possibility of such damages.
.
9. Accepting Warranty or Additional Liability. While redistributing
the Work or Derivative Works thereof, You may choose to offer,
and charge a fee for, acceptance of support, warranty, indemnity,
or other liability obligations and/or rights consistent with this
License. However, in accepting such obligations, You may act only
on Your own behalf and on Your sole responsibility, not on behalf
of any other Contributor, and only if You agree to indemnify,
defend, and hold each Contributor harmless for any liability
incurred by, or claims asserted against, such Contributor by reason
of your accepting any such warranty or additional liability.
.
END OF TERMS AND CONDITIONS
Files: src/poetry/core/_vendor/packaging/LICENSE.BSD
Copyright: Donald Stufft and individual contributors.
License: BSD-2-Clause
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:
.
1. Redistributions of source code must retain the above copyright notice,
this list of conditions and the following disclaimer.
.
2. Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the
documentation and/or other materials provided with the distribution.
.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
Files: src/poetry/core/_vendor/pyrsistent/_toolz.py
Copyright: 2013 Matthew Rocklin
License: BSD-3-Clause
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:
.
a. Redistributions of source code must retain the above copyright notice,
this list of conditions and the following disclaimer.
b. Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the
documentation and/or other materials provided with the distribution.
c. Neither the name of toolz nor the names of its contributors
may be used to endorse or promote products derived from this software
without specific prior written permission.
.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.
.
On Debian systems, the complete text of the BSD 3-clause "New" or "Revised"
License can be found in `/usr/share/common-licenses/BSD'.
Files: src/poetry/core/_vendor/lark/__pyinstaller/hook-lark.py
Copyright: 2017-2020 PyInstaller Development Team.
License: __UNKNOWN__ with unknown exception *** check multiple exceptions ***
Distributed under the terms of the GNU General Public License (version 2
or later) with exception for distributing the bootloader.
.
The full license is in the file COPYING.txt, distributed with this software.
.
SPDX-License-Identifier: (GPL-2.0-or-later WITH Bootloader-exception)
#----------------------------------------------------------------------------
# Files marked as NO_LICENSE_TEXT_FOUND may be covered by the following
# license/copyright files.
#----------------------------------------------------------------------------
# License file: LICENSE
Copyright (c) 2020 Sébastien Eustace
.
Permission is hereby granted, free of charge, to any person obtaining
a copy of this software and associated documentation files (the
"Software"), to deal in the Software without restriction, including
without limitation the rights to use, copy, modify, merge, publish,
distribute, sublicense, and/or sell copies of the Software, and to
permit persons to whom the Software is furnished to do so, subject to
the following conditions:
.
The above copyright notice and this permission notice shall be
included in all copies or substantial portions of the Software.
.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.