forked from openkylin/z3
18 lines
670 B
Diff
18 lines
670 B
Diff
Description: Fix build failure on riscv64
|
|
Author: Aurelien Jarno <aurelien@aurel32.net>
|
|
Origin: vendor, https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=948109#75
|
|
Bug-Debian: https://bugs.debian.org/948109
|
|
Last-Update: 2020-01-10
|
|
---
|
|
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -314,6 +314,7 @@
|
|
################################################################################
|
|
# Threading support
|
|
################################################################################
|
|
+set(THREADS_PREFER_PTHREAD_FLAG TRUE)
|
|
find_package(Threads)
|
|
list(APPEND Z3_DEPENDENT_LIBS ${CMAKE_THREAD_LIBS_INIT})
|
|
|