Merge pull request #468 from bulwahn/indigo-updates
Recent updates in the indigo distribution
This commit is contained in:
commit
0d2af46a09
|
@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc
|
|||
DEPENDS = "cmake python-empy python-catkin-pkg python-empy-native python-catkin-pkg-native"
|
||||
|
||||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "f7defbc3e46738987d62a65a9a70b3e9"
|
||||
SRC_URI[sha256sum] = "81aff570966cb99d6305881cce6a645080a9778380e7fc2e67a33ac972d7f4b7"
|
||||
SRC_URI[md5sum] = "d58460cc9112812d8c4e6ecf98bbcc85"
|
||||
SRC_URI[sha256sum] = "90a639d67db7f9039487af555e432a5b4b6e339f22892d75d03b823b3f38c947"
|
||||
|
||||
SRC_URI += "\
|
||||
file://0001-CATKIN_WORKSPACES-Don-t-require-.catkin-file.patch \
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "5c8282a3d4b100bcdd2b6fd5e619f35a"
|
||||
SRC_URI[sha256sum] = "5be04cdcfbc569d7b89c306628fd4414a3e2972ad2154548df2b86d4056393d9"
|
||||
SRC_URI[md5sum] = "4d124a7d874a00c622590f7a94d7d441"
|
||||
SRC_URI[sha256sum] = "5c0b0dd964805f37720f404b6f2d7c455c237b76ab161b5192d0852a09b0114a"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||
|
||||
|
|
|
@ -1,13 +1,13 @@
|
|||
DESCRIPTION = "This package provides a set of typedef's that allow using Eigen datatypes in STL containers."
|
||||
SECTION = "devel"
|
||||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
|
||||
|
||||
DEPENDS = "libeigen"
|
||||
|
||||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "fcc3fdda4010f92aa68f926cd3b8bdd0"
|
||||
SRC_URI[sha256sum] = "24d614921c4ec97f1d5c7905f5e896f1665b2e796c547b4a21504176b4680e47"
|
||||
SRC_URI[md5sum] = "1c259f56ba08d35e31c8c9126a894e2f"
|
||||
SRC_URI[sha256sum] = "cf1bcd3253aff0eb032f6d74b9b3c322c99f75ee66bd7034daee8bb2d2a422fc"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}"
|
||||
|
|
@ -1,107 +0,0 @@
|
|||
From 2607c82034cdfbf96fe372c9637b0133b6ba6970 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
Date: Sat, 12 Oct 2013 11:39:36 +0200
|
||||
Subject: [PATCH] check for CATKIN_ENABLE_TESTING
|
||||
|
||||
Upstream-Status: Accepted
|
||||
---
|
||||
CMakeLists.txt | 64 +++++++++++++++++++++++++++++++---------------------------
|
||||
package.xml | 2 +-
|
||||
2 files changed, 35 insertions(+), 31 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index aaf586d..ccb54f9 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -40,33 +40,35 @@ target_link_libraries(median ${catkin_LIBRARIES} ${Boost_LIBRARIES})
|
||||
add_library(transfer_function src/transfer_function.cpp)
|
||||
target_link_libraries(transfer_function ${catkin_LIBRARIES} ${Boost_LIBRARIES})
|
||||
|
||||
-# Test median filter
|
||||
-add_executable(median_test EXCLUDE_FROM_ALL test/test_median.cpp )
|
||||
-target_link_libraries(median_test median ${catkin_LIBRARIES} ${Boost_LIBRARIES} ${GTEST_LIBRARIES})
|
||||
-add_rostest(test/test_median.launch)
|
||||
-
|
||||
-# Test transfer function filter
|
||||
-add_executable(transfer_function_test EXCLUDE_FROM_ALL test/test_transfer_function.cpp)
|
||||
-target_link_libraries(transfer_function_test transfer_function ${catkin_LIBRARIES} ${Boost_LIBRARIES} ${GTEST_LIBRARIES})
|
||||
-add_rostest(test/test_transfer_function.launch)
|
||||
-
|
||||
-# Test mean filter
|
||||
-add_executable(mean_test EXCLUDE_FROM_ALL test/test_mean.cpp)
|
||||
-target_link_libraries(mean_test mean ${catkin_LIBRARIES} ${Boost_LIBRARIES} ${GTEST_LIBRARIES})
|
||||
-add_rostest(test/test_mean.launch)
|
||||
-
|
||||
-# Test params filter
|
||||
-add_executable(params_test EXCLUDE_FROM_ALL test/test_params.cpp)
|
||||
-target_link_libraries(params_test params ${catkin_LIBRARIES} ${Boost_LIBRARIES} ${GTEST_LIBRARIES})
|
||||
-add_rostest(test/test_params.launch)
|
||||
-
|
||||
-# Test plugin loading into filter chain
|
||||
-add_executable(chain_test EXCLUDE_FROM_ALL test/test_chain.cpp)
|
||||
-target_link_libraries(chain_test increment ${Boost_libraries} ${catkin_LIBRARIES} ${GTEST_LIBRARIES}) # Needed for OSX
|
||||
-add_rostest(test/test_chain.launch)
|
||||
-
|
||||
-# Test realtime safe buffer class
|
||||
-catkin_add_gtest(realtime_buffer_test EXCLUDE_FROM_ALL test/test_realtime_circular_buffer.cpp)
|
||||
+if(CATKIN_ENABLE_TESTING)
|
||||
+ # Test median filter
|
||||
+ add_executable(median_test EXCLUDE_FROM_ALL test/test_median.cpp )
|
||||
+ target_link_libraries(median_test median ${catkin_LIBRARIES} ${Boost_LIBRARIES} ${GTEST_LIBRARIES})
|
||||
+ add_rostest(test/test_median.launch)
|
||||
+
|
||||
+ # Test transfer function filter
|
||||
+ add_executable(transfer_function_test EXCLUDE_FROM_ALL test/test_transfer_function.cpp)
|
||||
+ target_link_libraries(transfer_function_test transfer_function ${catkin_LIBRARIES} ${Boost_LIBRARIES} ${GTEST_LIBRARIES})
|
||||
+ add_rostest(test/test_transfer_function.launch)
|
||||
+
|
||||
+ # Test mean filter
|
||||
+ add_executable(mean_test EXCLUDE_FROM_ALL test/test_mean.cpp)
|
||||
+ target_link_libraries(mean_test mean ${catkin_LIBRARIES} ${Boost_LIBRARIES} ${GTEST_LIBRARIES})
|
||||
+ add_rostest(test/test_mean.launch)
|
||||
+
|
||||
+ # Test params filter
|
||||
+ add_executable(params_test EXCLUDE_FROM_ALL test/test_params.cpp)
|
||||
+ target_link_libraries(params_test params ${catkin_LIBRARIES} ${Boost_LIBRARIES} ${GTEST_LIBRARIES})
|
||||
+ add_rostest(test/test_params.launch)
|
||||
+
|
||||
+ # Test plugin loading into filter chain
|
||||
+ add_executable(chain_test EXCLUDE_FROM_ALL test/test_chain.cpp)
|
||||
+ target_link_libraries(chain_test increment ${Boost_libraries} ${catkin_LIBRARIES} ${GTEST_LIBRARIES}) # Needed for OSX
|
||||
+ add_rostest(test/test_chain.launch)
|
||||
+
|
||||
+ # Test realtime safe buffer class
|
||||
+ catkin_add_gtest(realtime_buffer_test EXCLUDE_FROM_ALL test/test_realtime_circular_buffer.cpp)
|
||||
+endif()
|
||||
|
||||
##############################################################################
|
||||
# Install
|
||||
@@ -88,6 +90,8 @@ install(FILES default_plugins.xml
|
||||
DESTINATION ${CATKIN_PACKAGE_SHARE_DESTINATION}
|
||||
)
|
||||
|
||||
-if(TARGET tests)
|
||||
-add_dependencies(tests median_test transfer_function_test mean_test params_test chain_test)
|
||||
-endif()
|
||||
\ No newline at end of file
|
||||
+if(CATKIN_ENABLE_TESTING)
|
||||
+ if(TARGET tests)
|
||||
+ add_dependencies(tests median_test transfer_function_test mean_test params_test chain_test)
|
||||
+ endif()
|
||||
+endif()
|
||||
diff --git a/package.xml b/package.xml
|
||||
index c5bc897..dd66070 100644
|
||||
--- a/package.xml
|
||||
+++ b/package.xml
|
||||
@@ -11,7 +11,7 @@
|
||||
<license>BSD</license>
|
||||
<url>http://ros.org/wiki/filters</url>
|
||||
|
||||
- <buildtool_depend>catkin</buildtool_depend>
|
||||
+ <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
|
||||
|
||||
<build_depend>roslib</build_depend>
|
||||
<build_depend>rosconsole</build_depend>
|
||||
--
|
||||
1.8.1.2
|
||||
|
|
@ -1,34 +0,0 @@
|
|||
From 5aef0d6619394df17bffe743071295ad041b5794 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
Date: Tue, 4 Feb 2014 16:02:09 +0100
|
||||
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
|
||||
|
||||
Upstream-Status: Accepted
|
||||
---
|
||||
CMakeLists.txt | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index ccb54f9..97eea51 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -5,7 +5,7 @@ project(filters)
|
||||
# Find dependencies
|
||||
##############################################################################
|
||||
|
||||
-find_package(catkin REQUIRED COMPONENTS pluginlib roslib roscpp rosconsole rostest)
|
||||
+find_package(catkin REQUIRED COMPONENTS pluginlib roslib roscpp rosconsole)
|
||||
find_package(Boost COMPONENTS system filesystem thread REQUIRED)
|
||||
|
||||
include_directories(
|
||||
@@ -41,6 +41,7 @@ add_library(transfer_function src/transfer_function.cpp)
|
||||
target_link_libraries(transfer_function ${catkin_LIBRARIES} ${Boost_LIBRARIES})
|
||||
|
||||
if(CATKIN_ENABLE_TESTING)
|
||||
+ find_package(rostest)
|
||||
# Test median filter
|
||||
add_executable(median_test EXCLUDE_FROM_ALL test/test_median.cpp )
|
||||
target_link_libraries(median_test median ${catkin_LIBRARIES} ${Boost_LIBRARIES} ${GTEST_LIBRARIES})
|
||||
--
|
||||
1.8.3.2
|
||||
|
|
@ -6,10 +6,7 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9de
|
|||
DEPENDS = "roslib rosconsole roscpp pluginlib"
|
||||
|
||||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "0dd26504be16afa7816e9a5aa11715f1"
|
||||
SRC_URI[sha256sum] = "fb71f1fbeaf89726877fce66dce1db8957c5cc6dffa1973d6a104a10233f8237"
|
||||
|
||||
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch; \
|
||||
file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch"
|
||||
SRC_URI[md5sum] = "93b0685f061351dd2169f6b7f5373ca6"
|
||||
SRC_URI[sha256sum] = "6632c8bc2f3c47db6f69d136ccf58a1963ac0c83f5f542173caaebd2c7086160"
|
||||
|
||||
inherit catkin
|
|
@ -4,8 +4,8 @@ LICENSE = "BSD"
|
|||
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
|
||||
|
||||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "e437cdeef16423f7f0baab77c1667ba8"
|
||||
SRC_URI[sha256sum] = "af979bfa351b6b5a6006680bea195570f4b35dea8bcfeca7bbcdd00a108fefd9"
|
||||
SRC_URI[md5sum] = "942b0151a038683254230cfed22dced6"
|
||||
SRC_URI[sha256sum] = "d7627a2df169e4e8208347d9215e47c723a015b67ef3ed8cda8b61b6cfbf94d2"
|
||||
|
||||
inherit catkin
|
||||
|
|
@ -1,6 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "a85da2e856d54320d89dd95b9719cf78"
|
||||
SRC_URI[sha256sum] = "1662f0c14e11a8079a0c1325813591ddf4bafae9605ee10a920f42f15dc1face"
|
||||
SRC_URI[md5sum] = "1a15fc5764478d1297417d3ca83ad200"
|
||||
SRC_URI[sha256sum] = "fba4c223e85923060d76f1113b346207b2d36cda0e2c3393ec96ff99ba918dbe"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "0dbcd5a3154947fdf63476b90b421ab0"
|
||||
SRC_URI[sha256sum] = "e0d5c01e160ceb82aa8c394d40b9f39deb1f005027eefe1e0d29c0417ae47353"
|
||||
SRC_URI[md5sum] = "93262ecca39761feb87ec0538217bbb5"
|
||||
SRC_URI[sha256sum] = "13d434e2d46e13af05398f3cbacffb2c69e2d015f6827d848f799a28d23e816d"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "095c1dd8ed0fbd5775ba6986f4e4a074"
|
||||
SRC_URI[sha256sum] = "91e0d491bd08dce8629876bf6005a1aaabcb130413ed749c4ab168e17f0118fa"
|
||||
SRC_URI[md5sum] = "13ce3d3c86dbe7f8e7b9eed26c8a7418"
|
||||
SRC_URI[sha256sum] = "e5138f55e537a88c2c53b12a8bb4cb5b3bfcd247b1c49d8b40d01ce32c33d5b7"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||
|
||||
|
|
|
@ -1,58 +0,0 @@
|
|||
From 3a821331fb0884607b6c77865ed9fbc1e8197e20 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
Date: Sat, 28 Feb 2015 20:55:42 +0100
|
||||
Subject: [PATCH] CMakeLists.txt: check launch file if testing is on
|
||||
|
||||
When building with CATKIN_ENABLE_TESTING deactivated, configure
|
||||
fails with:
|
||||
|
||||
| -- Using CATKIN_ENABLE_TESTING: 0
|
||||
| -- catkin 0.6.14
|
||||
| -- Using these message generators: gencpp;genlisp;genpy
|
||||
| CMake Error at /opt/ros/indigo/share/roslaunch/cmake/roslaunch-extras.cmake:35 (catkin_run_tests_target):
|
||||
| Unknown CMake command "catkin_run_tests_target".
|
||||
| Call Stack (most recent call first):
|
||||
| CMakeLists.txt:34 (roslaunch_add_file_check)
|
||||
|
|
||||
|
|
||||
| -- Configuring incomplete, errors occurred!
|
||||
|
||||
Configure fails as the test command 'catkin_run_tests_target' is
|
||||
only defined in catkin if CATKIN_ENABLE_TESTING is enabled.
|
||||
Hence, this commit changes CMakeLists.txt so that the command is
|
||||
only used if CATKIN_ENABLE_TESTING is enabled.
|
||||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
|
||||
Upstream-Status: Submitted [https://github.com/ros-perception/imu_pipeline/pull/6]
|
||||
---
|
||||
imu_transformer/CMakeLists.txt | 6 ++++--
|
||||
1 file changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/imu_transformer/CMakeLists.txt b/imu_transformer/CMakeLists.txt
|
||||
index 9a498dc..7a9dfc6 100644
|
||||
--- a/imu_transformer/CMakeLists.txt
|
||||
+++ b/imu_transformer/CMakeLists.txt
|
||||
@@ -5,7 +5,6 @@ find_package(catkin REQUIRED COMPONENTS
|
||||
message_filters
|
||||
nodelet
|
||||
roscpp
|
||||
- roslaunch
|
||||
sensor_msgs
|
||||
geometry_msgs
|
||||
tf2
|
||||
@@ -31,7 +30,10 @@ target_link_libraries(imu_transformer_nodelet ${catkin_LIBRARIES})
|
||||
add_executable(imu_transformer_node src/imu_transformer_node.cpp)
|
||||
target_link_libraries(imu_transformer_node ${catkin_LIBRARIES})
|
||||
|
||||
-roslaunch_add_file_check(launch)
|
||||
+if(CATKIN_ENABLE_TESTING)
|
||||
+ find_package(roslaunch REQUIRED)
|
||||
+ roslaunch_add_file_check(launch)
|
||||
+endif()
|
||||
|
||||
install(TARGETS imu_transformer_node imu_transformer_nodelet
|
||||
RUNTIME DESTINATION ${CATKIN_PACKAGE_BIN_DESTINATION}
|
||||
--
|
||||
1.9.3
|
||||
|
|
@ -8,5 +8,3 @@ DEPENDS = "geometry-msgs nodelet message-filters roscpp roslaunch sensor-msgs \
|
|||
tf2 tf2-ros tf2-sensor-msgs topic-tools"
|
||||
|
||||
require imu-pipeline.inc
|
||||
|
||||
SRC_URI += "file://0001-CMakeLists.txt-check-launch-file-if-testing-is-on.patch;striplevel=2"
|
|
@ -1,6 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros-drivers/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "65e20a0b03e89c48d2de4625d8a40581"
|
||||
SRC_URI[sha256sum] = "da6fddad4ebaff99d37bf7746bed9b8ea3e5ab5ce8af6bcc4faa22cbc68641d5"
|
||||
SRC_URI[md5sum] = "405b17d70c464786d3fe7a73bf8f95b1"
|
||||
SRC_URI[sha256sum] = "020b952e6c2fa8057ec878a07a290ac027f58108160bcbb0b37d6ddfa2e9ebf4"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
SRC_URI = "https://github.com/mavlink/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "7d8fd22c44a9a5d384cd34c5a329d443"
|
||||
SRC_URI[md5sum] = "eea22457db6c7b8a17bba0223a41dceb"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "1cf720ba817ec0db2172d87030c9ad5e"
|
||||
SRC_URI[sha256sum] = "29e9ea1c4f76188d369ebde8e94adcdf92260bd9f6d766ce533dbd91e40ee356"
|
||||
SRC_URI[md5sum] = "feb4e2d49ba8e4607524d4e91aeec4c9"
|
||||
SRC_URI[sha256sum] = "6313abe64e29fbbe87d8e108c13ccd075de4ff8f01b85f988716b9475d312112"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||
|
||||
|
|
|
@ -1,56 +0,0 @@
|
|||
From 6b9e3cab6b09c9b65a7bef1374e079a87711a473 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
Date: Wed, 21 Sep 2016 21:22:30 +0200
|
||||
Subject: [PATCH] [urdf] address gcc6 build error and tune (#156)
|
||||
|
||||
With gcc6, compiling fails with `stdlib.h: No such file or directory`,
|
||||
as including '-isystem /usr/include' breaks with gcc6, cf.,
|
||||
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.
|
||||
|
||||
This commit addresses this issue for this package in the same way
|
||||
it was addressed in various other ROS packages. A list of related
|
||||
commits and pull requests is at:
|
||||
|
||||
https://github.com/ros/rosdistro/issues/12783
|
||||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
|
||||
Upstream-Status: Accepted [https://github.com/ros/robot_model/commit/6b9e3cab6b09c9b65a7bef1374e079a87711a473]
|
||||
|
||||
This patch has been generated with:
|
||||
`git format-patch -1 6b9e3cab6b09c9b65a7bef1374e079a87711a473`
|
||||
in the robot_model repository.
|
||||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
---
|
||||
urdf/CMakeLists.txt | 7 +++----
|
||||
1 file changed, 3 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/urdf/CMakeLists.txt b/urdf/CMakeLists.txt
|
||||
index ae7437e..a0872e9 100644
|
||||
--- a/urdf/CMakeLists.txt
|
||||
+++ b/urdf/CMakeLists.txt
|
||||
@@ -20,17 +20,16 @@ catkin_package(
|
||||
DEPENDS urdfdom_headers urdfdom Boost pcrecpp
|
||||
)
|
||||
|
||||
-include_directories(SYSTEM ${Boost_INCLUDE_DIR})
|
||||
-link_directories(${Boost_LIBRARY_DIRS})
|
||||
-
|
||||
include_directories(
|
||||
include
|
||||
+ ${Boost_INCLUDE_DIR}
|
||||
${catkin_INCLUDE_DIRS}
|
||||
${urdfdom_INCLUDE_DIRS}
|
||||
${urdfdom_headers_INCLUDE_DIRS}
|
||||
${TinyXML_INCLUDE_DIRS}
|
||||
)
|
||||
-link_directories(${catkin_LIBRARY_DIRS})
|
||||
+
|
||||
+link_directories(${Boost_LIBRARY_DIRS} ${catkin_LIBRARY_DIRS})
|
||||
|
||||
add_library(${PROJECT_NAME} src/model.cpp src/rosconsole_bridge.cpp)
|
||||
target_link_libraries(${PROJECT_NAME} ${TinyXML_LIBRARIES} ${catkin_LIBRARIES} ${urdfdom_LIBRARIES})
|
||||
--
|
||||
2.5.5
|
||||
|
|
@ -6,5 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=15;endline=15;md5=d566ef916e9de
|
|||
DEPENDS = "rosconsole-bridge roscpp urdfdom-headers urdf-parser-plugin pluginlib urdfdom cmake-modules libtinyxml class-loader"
|
||||
|
||||
require robot-model.inc
|
||||
|
||||
SRC_URI += "file://0001-urdf-address-gcc6-build-error-and-tune-156.patch;striplevel=2"
|
|
@ -1,6 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "cad698f12fab7e0786e2e1355fa22cf7"
|
||||
SRC_URI[sha256sum] = "bb687aa0f10aa8a87e42d1592b534bc602f5923f90bffdf51031f59c4bfe362a"
|
||||
SRC_URI[md5sum] = "7f731bf38da6099d1d7b0083b568836b"
|
||||
SRC_URI[sha256sum] = "fbfbecbdbd3c0fb752c5757aac843cc9bfffe71ac7b1b094e2d1142567f02fa1"
|
||||
|
||||
ROS_PKG_SUBDIR ?= ""
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_PKG_SUBDIR}/${ROS_BPN}"
|
||||
|
|
|
@ -1,34 +0,0 @@
|
|||
From 74674c49a64abbdcdd5aeea016997af2959c6f05 Mon Sep 17 00:00:00 2001
|
||||
From: Hodorgasm <nsane457@gmail.com>
|
||||
Date: Mon, 3 Oct 2016 20:32:20 -0400
|
||||
Subject: [PATCH] Add '#Include <vector>' to fix building on GCC-6
|
||||
|
||||
Don't rely on transitive header inclusion to declare std::vector as building with GCC-6 fails due to no '#Include <vector>' statement.
|
||||
|
||||
Upstream-Status: Backport [https://github.com/ros/ros_comm/commit/74674c49a64abbdcdd5aeea016997af2959c6f05]
|
||||
|
||||
This patch has been generated with:
|
||||
`git format-patch -1 74674c49a64abbdcdd5aeea016997af2959c6f05`
|
||||
in the kinetic branch of the ros_comm repository.
|
||||
This patch applies without modifications to the indigo release 1.11.20.
|
||||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
---
|
||||
tools/rosconsole/include/ros/console.h | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/tools/rosconsole/include/ros/console.h b/tools/rosconsole/include/ros/console.h
|
||||
index 4d2a86b..28901d7 100644
|
||||
--- a/tools/rosconsole/include/ros/console.h
|
||||
+++ b/tools/rosconsole/include/ros/console.h
|
||||
@@ -40,6 +40,7 @@
|
||||
#include <cstdarg>
|
||||
#include <ros/macros.h>
|
||||
#include <map>
|
||||
+#include <vector>
|
||||
|
||||
#ifdef ROSCONSOLE_BACKEND_LOG4CXX
|
||||
#include "log4cxx/level.h"
|
||||
--
|
||||
2.5.5
|
||||
|
|
@ -8,5 +8,3 @@ DEPENDS = "apr boost cpp-common log4cxx rostime rosunit"
|
|||
require ros-comm.inc
|
||||
|
||||
ROS_PKG_SUBDIR = "tools"
|
||||
|
||||
SRC_URI += "file://0001-Add-Include-vector-to-fix-building-on-GCC-6.patch;striplevel=3"
|
|
@ -9,6 +9,6 @@ SRC_URI += "file://0001-Fix-PKG_NAME-_INCLUDE_DIR-variable.patch"
|
|||
|
||||
S = "${WORKDIR}/git"
|
||||
|
||||
DEPENDS = "python-setuptools"
|
||||
DEPENDS = "python-setuptools-native"
|
||||
|
||||
inherit catkin
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "6ab08e73ad24e1b67381c42c7f78165c"
|
||||
SRC_URI[sha256sum] = "be7af9ee617f5a427782d0bd0bdc93d665610c8e7a9329d3089dee1be99fffef"
|
||||
SRC_URI[md5sum] = "06835d9eefbfbcc0b575529de19f8e9b"
|
||||
SRC_URI[sha256sum] = "ecc778090b9e404353c3afe42f88369d8593d2da11a4b39e68feca6d8a59279a"
|
||||
|
||||
ROS_PKG_SUBDIR ?= ""
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_PKG_SUBDIR}/${ROS_BPN}"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "fa45647beaed9d551775393768bbf8fa"
|
||||
SRC_URI[sha256sum] = "85028afb1e1630b47890d3c92bcb7edf61f4be04281669f73f000312621bf66d"
|
||||
SRC_URI[md5sum] = "137cf14d945df2a08bf963ead8eefd4c"
|
||||
SRC_URI[sha256sum] = "9b3bc5363e026f55116fc85b806a93a23d1fcfd761922400dd7e13bcad94d5b0"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||
|
||||
|
|
|
@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=6;endline=6;md5=d566ef916e9dedc
|
|||
DEPENDS = "boost cmake-modules python-rospkg-native libtinyxml"
|
||||
|
||||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "6608b514bc7aff7e8350855369228cd8"
|
||||
SRC_URI[sha256sum] = "e11d7aebc61c71fd4b3d1d6c775766d6d58573a79d5076d7f13595eeeeba0ad2"
|
||||
SRC_URI[md5sum] = "f415d53b620d35ce674959ac7616d202"
|
||||
SRC_URI[sha256sum] = "a8fecbe03f9757510fe47137642e39a7c31b823d5bf7fa7890acc1169106b638"
|
||||
|
||||
inherit catkin
|
||||
|
|
@ -1,65 +0,0 @@
|
|||
From aaf08c721c35a654c0ef0ac013e18db1b111bfdc Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
Date: Wed, 21 Sep 2016 11:27:28 +0200
|
||||
Subject: [PATCH] address gcc6 build error in cv_bridge and tune
|
||||
|
||||
With gcc6, compiling fails with `stdlib.h: No such file or directory`,
|
||||
as including '-isystem /usr/include' breaks with gcc6, cf.,
|
||||
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129
|
||||
|
||||
This commit addresses this issue for cv_bridge in the same way
|
||||
it was done in the commit ead421b8 [1] for image_geometry.
|
||||
This issue was also addressed in various other ROS packages.
|
||||
A list of related commits and pull requests is at:
|
||||
|
||||
https://github.com/ros/rosdistro/issues/12783
|
||||
|
||||
[1] https://github.com/ros-perception/vision_opencv/commit/ead421b85eeb750cbf7988657015296ed6789bcf
|
||||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
|
||||
Upstream-Status: Accepted [https://github.com/ros-perception/vision_opencv/commit/aaf08c721c35a654c0ef0ac013e18db1b111bfdc]
|
||||
|
||||
This patch has been generated with:
|
||||
`git format-patch -1 aaf08c721c35a654c0ef0ac013e18db1b111bfdc`
|
||||
in the vision_opencv repository.
|
||||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
---
|
||||
cv_bridge/CMakeLists.txt | 3 +--
|
||||
cv_bridge/src/CMakeLists.txt | 5 +----
|
||||
2 files changed, 2 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/cv_bridge/CMakeLists.txt b/cv_bridge/CMakeLists.txt
|
||||
index 075fbbd..cce8af7 100644
|
||||
--- a/cv_bridge/CMakeLists.txt
|
||||
+++ b/cv_bridge/CMakeLists.txt
|
||||
@@ -19,8 +19,7 @@ catkin_package(
|
||||
|
||||
catkin_python_setup()
|
||||
|
||||
-include_directories(SYSTEM ${Boost_INCLUDE_DIRS} ${OpenCV_INCLUDE_DIRS})
|
||||
-include_directories(include ${catkin_INCLUDE_DIRS})
|
||||
+include_directories(include ${Boost_INCLUDE_DIRS} ${OpenCV_INCLUDE_DIRS} ${catkin_INCLUDE_DIRS})
|
||||
|
||||
if(NOT ANDROID)
|
||||
add_subdirectory(python)
|
||||
diff --git a/cv_bridge/src/CMakeLists.txt b/cv_bridge/src/CMakeLists.txt
|
||||
index 8ec321c..37ba30e 100644
|
||||
--- a/cv_bridge/src/CMakeLists.txt
|
||||
+++ b/cv_bridge/src/CMakeLists.txt
|
||||
@@ -26,10 +26,7 @@ if(NOT PYTHON_NUMPY_INCLUDE_DIR)
|
||||
endif(PYTHON_NUMPY_PROCESS EQUAL 0)
|
||||
endif(NOT PYTHON_NUMPY_INCLUDE_DIR)
|
||||
|
||||
-include_directories(SYSTEM ${PYTHON_INCLUDE_PATH}
|
||||
- ${Boost_INCLUDE_DIRS}
|
||||
- ${PYTHON_NUMPY_INCLUDE_DIR} # cv_bridge module uses NumPy functions
|
||||
-)
|
||||
+include_directories(${PYTHON_INCLUDE_PATH} ${Boost_INCLUDE_DIRS} ${PYTHON_NUMPY_INCLUDE_DIR})
|
||||
|
||||
if (PYTHON_VERSION_MAJOR VERSION_EQUAL 3)
|
||||
add_definitions(-DPYTHON3)
|
||||
--
|
||||
2.5.5
|
||||
|
|
@ -6,5 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9de
|
|||
DEPENDS = "boost opencv rosconsole sensor-msgs python-numpy-native"
|
||||
|
||||
require vision-opencv.inc
|
||||
|
||||
SRC_URI += "file://0001-address-gcc6-build-error-in-cv_bridge-and-tune.patch;striplevel=2"
|
|
@ -1,6 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "3a31b0f7feb39d043ad1b260811197c8"
|
||||
SRC_URI[sha256sum] = "c075229b5e3877dd6bc4f28262182a7760245ba7b0471b6242a7d774d6d40c29"
|
||||
SRC_URI[md5sum] = "f0a79aead8acadaf12f9fee676615860"
|
||||
SRC_URI[sha256sum] = "c8da1314d18e3da895a89966709c3539ed9fe0fb2d8cfd29ee4d3b138d7b48f4"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||
|
||||
|
|
Loading…
Reference in New Issue