depth-image-proc: drop patch not needed after libeigen update

This commit is contained in:
Lukas Bulwahn 2017-11-02 09:55:09 +01:00
parent c456672efc
commit 1a503b19c8
2 changed files with 0 additions and 35 deletions

View File

@ -1,33 +0,0 @@
From 579993db0e7ef1f6820b39f4e7598324c0bde097 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
Date: Tue, 2 May 2017 08:15:28 +0200
Subject: [PATCH] find Eigen3 with ROS cmake_modules script
Upstream-Status: Pending
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
---
depth_image_proc/CMakeLists.txt | 7 ++-----
1 file changed, 2 insertions(+), 5 deletions(-)
diff --git a/depth_image_proc/CMakeLists.txt b/depth_image_proc/CMakeLists.txt
index 060d295..dbe26a5 100644
--- a/depth_image_proc/CMakeLists.txt
+++ b/depth_image_proc/CMakeLists.txt
@@ -8,11 +8,8 @@ catkin_package(
LIBRARIES ${PROJECT_NAME})
find_package(Boost REQUIRED)
-find_package(Eigen3 QUIET)
-if(NOT EIGEN3_FOUND)
- find_package(Eigen REQUIRED)
- set(EIGEN3_INCLUDE_DIRS ${EIGEN_INCLUDE_DIRS})
-endif()
+find_package(Eigen REQUIRED)
+set(EIGEN3_INCLUDE_DIRS ${EIGEN_INCLUDE_DIRS})
find_package(OpenCV REQUIRED)
include_directories(include ${BOOST_INCLUDE_DIRS} ${catkin_INCLUDE_DIRS} ${EIGEN3_INCLUDE_DIRS})
--
1.9.1

View File

@ -6,5 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=14;endline=14;md5=d566ef916e9de
DEPENDS = "boost cv-bridge eigen-conversions image-geometry image-transport message-filters nodelet sensor-msgs stereo-msgs tf2 tf2-ros"
require image-pipeline.inc
SRC_URI += "file://0001-find-Eigen3-with-ROS-cmake_modules-script.patch;striplevel=2"