python-pycrypto: drop recipe fully included in meta-python
This commit is contained in:
parent
c4314a1c13
commit
27e95fdd35
|
@ -1,22 +0,0 @@
|
||||||
Index: pycrypto-2.6/setup.py
|
|
||||||
===================================================================
|
|
||||||
--- pycrypto-2.6.orig/setup.py
|
|
||||||
+++ pycrypto-2.6/setup.py
|
|
||||||
@@ -271,7 +271,8 @@ class PCTBuildConfigure(Command):
|
|
||||||
if not os.path.exists("config.status"):
|
|
||||||
if os.system("chmod 0755 configure") != 0:
|
|
||||||
raise RuntimeError("chmod error")
|
|
||||||
- cmd = "sh configure" # we use "sh" here so that it'll work on mingw32 with standard python.org binaries
|
|
||||||
+ host = os.environ.get("HOST_SYS")
|
|
||||||
+ cmd = "ac_cv_func_malloc_0_nonnull=yes sh configure --host " + host # we use "sh" here so that it'll work on mingw32 with standard python.org binaries
|
|
||||||
if self.verbose < 1:
|
|
||||||
cmd += " -q"
|
|
||||||
if os.system(cmd) != 0:
|
|
||||||
@@ -370,7 +371,7 @@ kw = {'name':"pycrypto",
|
|
||||||
'ext_modules': plat_ext + [
|
|
||||||
# _fastmath (uses GNU mp library)
|
|
||||||
Extension("Crypto.PublicKey._fastmath",
|
|
||||||
- include_dirs=['src/','/usr/include/'],
|
|
||||||
+ include_dirs=['src/'],
|
|
||||||
libraries=['gmp'],
|
|
||||||
sources=["src/_fastmath.c"]),
|
|
|
@ -1,33 +0,0 @@
|
||||||
DESCRIPTION = "Cryptographic modules for Python."
|
|
||||||
HOMEPAGE = "http://www.pycrypto.org/"
|
|
||||||
SECTION = "devel/python"
|
|
||||||
LICENSE = "PSFv2"
|
|
||||||
LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d"
|
|
||||||
|
|
||||||
SRCNAME = "pycrypto"
|
|
||||||
|
|
||||||
SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
|
|
||||||
file://cross-compiling.patch"
|
|
||||||
|
|
||||||
SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda"
|
|
||||||
SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c"
|
|
||||||
|
|
||||||
S = "${WORKDIR}/${SRCNAME}-${PV}"
|
|
||||||
|
|
||||||
export STAGING_INCDIR
|
|
||||||
export STAGING_LIBDIR
|
|
||||||
export BUILD_SYS
|
|
||||||
export HOST_SYS
|
|
||||||
|
|
||||||
inherit autotools autotools-brokensep distutils
|
|
||||||
|
|
||||||
DEPENDS += " gmp"
|
|
||||||
|
|
||||||
do_compile[noexec] = "1"
|
|
||||||
|
|
||||||
# We explicitly call distutils_do_install, since we want it to run, but
|
|
||||||
# *don't* want the autotools install to run, since this package doesn't
|
|
||||||
# provide a "make install" target.
|
|
||||||
do_install() {
|
|
||||||
distutils_do_install
|
|
||||||
}
|
|
|
@ -1,3 +0,0 @@
|
||||||
require python-pycrypto.inc
|
|
||||||
|
|
||||||
inherit distutils
|
|
|
@ -1,3 +0,0 @@
|
||||||
include python-pycrypto.inc
|
|
||||||
|
|
||||||
inherit distutils3
|
|
Loading…
Reference in New Issue