dynamic-reconfigure: updating to 1.5.45
This commit removes the patch that has been accepted upstream and has been included in the version 1.5.45. Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
This commit is contained in:
parent
5185618e5a
commit
2fae5e367e
|
@ -1,45 +0,0 @@
|
|||
From b2f10174c48333f7a0ce8c01b86536f959d92348 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
Date: Wed, 21 Sep 2016 13:16:07 +0200
|
||||
Subject: [PATCH] address gcc6 build error
|
||||
|
||||
With gcc6, compiling fails with `stdlib.h: No such file or directory`,
|
||||
as including '-isystem /usr/include' breaks with gcc6, cf.,
|
||||
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.
|
||||
|
||||
This commit addresses this issue for this package in the same way
|
||||
it was addressed in various other ROS packages. A list of related
|
||||
commits and pull requests is at:
|
||||
|
||||
https://github.com/ros/rosdistro/issues/12783
|
||||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
|
||||
Upstream-Status: Accepted [https://github.com/ros/dynamic_reconfigure/commit/b2f10174c48333f7a0ce8c01b86536f959d92348]
|
||||
|
||||
This patch has been generated with:
|
||||
`git format-patch -1 b2f10174c48333f7a0ce8c01b86536f959d92348`
|
||||
in the dynamic_reconfigure repository.
|
||||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
---
|
||||
CMakeLists.txt | 3 +--
|
||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index ce896b9..60c6333 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -4,8 +4,7 @@ project(dynamic_reconfigure)
|
||||
find_package(catkin REQUIRED COMPONENTS message_generation roscpp std_msgs)
|
||||
find_package(Boost REQUIRED COMPONENTS system thread)
|
||||
|
||||
-include_directories(include ${catkin_INCLUDE_DIRS})
|
||||
-include_directories(SYSTEM ${Boost_INCLUDE_DIRS})
|
||||
+include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
|
||||
|
||||
catkin_python_setup()
|
||||
|
||||
--
|
||||
2.5.5
|
||||
|
|
@ -7,10 +7,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc
|
|||
DEPENDS = "roscpp std-msgs roslib"
|
||||
|
||||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "5728cc591b90e7ddd42b936e74e3062c"
|
||||
SRC_URI[sha256sum] = "f1b073c36fd937bd8697bc92ec38926f9194069e6e8d80ab70eb09610720ee7f"
|
||||
|
||||
SRC_URI += "file://0001-address-gcc6-build-error.patch"
|
||||
SRC_URI[md5sum] = "368adb420f761be39cc0b9840237d599"
|
||||
SRC_URI[sha256sum] = "409807fea59061a3d5788e6fa8c46ed2e2198cb1a8d59c66a417049b8e9cf754"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}"
|
||||
|
Loading…
Reference in New Issue