ros-tutorials: updating to 0.5.3
The patch provided upstream is part of 0.5.2 and hence is removed.
This commit is contained in:
parent
bf4ebe00a7
commit
3d0f67ced6
|
@ -1,6 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "e4e8e31d3c8b47667101d4283e38ceca"
|
||||
SRC_URI[sha256sum] = "f3b8bab93101d0cb48d925c57ed66d20664d0a91dd70f80f7d74667ff9a10e8e"
|
||||
SRC_URI[md5sum] = "e626ae457fec17f234f692782c80ea8a"
|
||||
SRC_URI[sha256sum] = "7e223f235b0aa80437f93e729d0f8a1446a07941d8870590981f2562e78c1c1c"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||
|
||||
|
|
|
@ -1,34 +0,0 @@
|
|||
From 8e1fdde288fe2f1edb20e504846dabac026ca2ff Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
Date: Tue, 4 Feb 2014 16:07:10 +0100
|
||||
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
|
||||
|
||||
Upstream-Status: Backport [Accepted in indigo-devel branch]
|
||||
---
|
||||
rospy_tutorials/CMakeLists.txt | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/rospy_tutorials/CMakeLists.txt b/rospy_tutorials/CMakeLists.txt
|
||||
index b588dfc..5287af3 100644
|
||||
--- a/rospy_tutorials/CMakeLists.txt
|
||||
+++ b/rospy_tutorials/CMakeLists.txt
|
||||
@@ -1,7 +1,7 @@
|
||||
cmake_minimum_required(VERSION 2.8.3)
|
||||
project(rospy_tutorials)
|
||||
|
||||
-find_package(catkin REQUIRED COMPONENTS message_generation rostest std_msgs)
|
||||
+find_package(catkin REQUIRED COMPONENTS message_generation std_msgs)
|
||||
|
||||
add_message_files(DIRECTORY msg FILES Floats.msg HeaderString.msg)
|
||||
add_service_files(DIRECTORY srv FILES AddTwoInts.srv BadTwoInts.srv)
|
||||
@@ -27,6 +27,7 @@ foreach(T
|
||||
endforeach()
|
||||
|
||||
if(CATKIN_ENABLE_TESTING)
|
||||
+ find_package(rostest)
|
||||
foreach(T
|
||||
test/test-add-two-ints.launch
|
||||
test/test-peer-subscribe-notify.launch
|
||||
--
|
||||
1.8.3.2
|
||||
|
|
@ -6,5 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9de
|
|||
DEPENDS = "message-generation std-msgs cpp-common roscpp-serialization"
|
||||
|
||||
require ros-tutorials.inc
|
||||
|
||||
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;striplevel=2"
|
Loading…
Reference in New Issue