Merge pull request #478 from bulwahn/indigo-updates

recent updates in the indigo distribution
This commit is contained in:
Dmitry Rozhkov 2017-04-18 11:46:24 +03:00 committed by GitHub
commit 41fcd69f1c
24 changed files with 28 additions and 81 deletions

View File

@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9de
DEPENDS = "actionlib-msgs roscpp"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "27f247adad8441c2ac2316cfc4ce4427"
SRC_URI[sha256sum] = "e849e30363b7df0a92ec9179b9ff9833a72581003da9eb880fc3e21ef1f4667e"
SRC_URI[md5sum] = "55232c305dcadd9b265e512dc61edd9c"
SRC_URI[sha256sum] = "0e0eb18e964cfd25490875295950760fb468fd30cab707c0138ddada131be7c6"
inherit catkin

View File

@ -1,6 +1,6 @@
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "7832ec9a9e467e60747a886361624fb7"
SRC_URI[sha256sum] = "cdcad6a9a311bbe2f8f05ece55f595c0443b3a99e1c9ebd7b1c50ff05d6de123"
SRC_URI[md5sum] = "3afd0058ae7bc2868a5d086f7737465a"
SRC_URI[sha256sum] = "67d7f1cbfe1a007ba48aa477f722e185485006cbd0abdd1460f580d677f89643"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"

View File

@ -7,8 +7,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc
DEPENDS = "roscpp std-msgs roslib"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "200c2039d3d6e494e0b8aebd65f3bb5d"
SRC_URI[sha256sum] = "c3d782715f16c0ec3335e23d27ddb62f12eec3492e865003168c74bd212a6fbb"
SRC_URI[md5sum] = "f10a72f0c9cf1a8e7c6b8cccbbb6ca04"
SRC_URI[sha256sum] = "351b778ea8478faad7287e2c70219deb13114b4983cd09d6d5faa4825706664a"
S = "${WORKDIR}/${ROS_SP}"

View File

@ -5,4 +5,4 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=14;endline=14;md5=d566ef916e9de
DEPENDS = "roslib boost eigen-conversions fcl octomap eigen-stl-containers geometric-shapes kdl-parser moveit-msgs srdfdom cmake-modules"
require moveit-${PV}.inc
require moveit.inc

View File

@ -3,15 +3,14 @@ SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "moveit-core tf-conversions image-transport cv-bridge"
require moveit-${PV}.inc
require moveit.inc
ROS_BPN = "moveit_ros/perception"
SRC_URI = "https://github.com/ros-planning/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz \
file://0001-moveit_ros_perception-make-OpenGL-parts-optional.patch \
file://0002-Add-C-11-support-for-moveit_ros_perception-and-movei.patch \
SRC_URI += "file://0001-moveit_ros_perception-make-OpenGL-parts-optional.patch \
file://0002-Add-C-11-support-for-moveit_ros_perception-and-movei.patch \
"
EXTRA_OECMAKE_append = " -DBUILD_OPENGL=OFF"

View File

@ -1,49 +0,0 @@
From 6734257c8d611e7561372be93e31ea5c4887c7e2 Mon Sep 17 00:00:00 2001
From: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com>
Date: Wed, 25 Jan 2017 11:02:22 +0200
Subject: [PATCH 1/2] address gcc6 build error
With gcc6, compiling fails with `stdlib.h: No such file or directory`,
as including '-isystem /usr/include' breaks with gcc6, cf.,
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.
This commit addresses this issue for this package in almost the same way
it was addressed in various other ROS packages. A list of related
commits and pull requests is at:
https://github.com/ros/rosdistro/issues/12783
Particularly when searching for the Boost library CMake sets
Boost_INCLUDE_DIRS to @SYSROOT@/usr/include which should be
avoided in the `-isystem` option of gcc.
Upstream-Status: Accepted
Signed-off-by: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com>
---
CMakeLists.txt | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2f41991..4829da0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,11 +62,12 @@ catkin_package(
include_directories(${THIS_PACKAGE_INCLUDE_DIRS}
${catkin_INCLUDE_DIRS}
- )
+ ${Boost_INCLUDE_DIRS}
+)
include_directories(SYSTEM
${EIGEN_INCLUDE_DIRS}
- ${Boost_INCLUDE_DIRS}
- )
+)
+
link_directories(${Boost_LIBRARY_DIRS})
link_directories(${catkin_LIBRARY_DIRS})
--
2.7.4

View File

@ -5,11 +5,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=d566ef916e9de
DEPENDS = "moveit-core moveit-ros-perception dynamic-reconfigure ${PYTHON_PN}-rospkg libtinyxml"
require moveit-${PV}.inc
require moveit.inc
ROS_BPN = "moveit_ros/planning"
SRC_URI = "https://github.com/ros-planning/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz \
file://0001-address-gcc6-build-error.patch \
"
FILES_${PN} += "${ros_libdir}/moveit_ros_planning/*"

View File

@ -1,6 +1,6 @@
SRC_URI = "https://github.com/ros-planning/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "fadd453134bb64559b989d2b3f02ca28"
SRC_URI[sha256sum] = "d14103ddf4545f42acaabfcdda36eeff9a293e07269d339eeb7ac4ab6dd3c522"
SRC_URI[md5sum] = "6ebfe9fc33837fcea079bcd7f3741eb5"
SRC_URI[sha256sum] = "9ec381e6589a663b03f8468d095599b90b14e102be221f9b19dc8b833dbc05bb"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"

View File

@ -1,6 +1,6 @@
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "fd356be7e92f3425fc426209a928ad4a"
SRC_URI[sha256sum] = "65181dfe8070c9cd7ed2d16a9cb0204f2ab122fd3f960c4042a5cbf5566f6ede"
SRC_URI[md5sum] = "b453b5d5bb06ebfca393d9e8e3c845e2"
SRC_URI[sha256sum] = "50b8b3c01b577c8d71c92ec64ae516e030e2912bc5afcf66b2ada8bc39002544"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"

View File

@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc
DEPENDS = "boost class-loader rosconsole roslib libtinyxml"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "60b02ed04b105e1fee0c536fe4612183"
SRC_URI[sha256sum] = "9a8a81d39472bda8cc8a9b189b9dc8f602b13b97a132a153144785d9fc5b68b2"
SRC_URI[md5sum] = "eb443817a26dc03b7c063e9bbb82439f"
SRC_URI[sha256sum] = "53a0ccb7a4654d464271189fc44ba23d6be8d3ecdfb40506b9d9fb4a87f19d6c"
inherit catkin

View File

@ -2,15 +2,15 @@ DESCRIPTION = "This package retrieves data from url-format files such as \
http://, ftp://, package:// file://, etc., and loads the data into memory."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=16;endline=16;md5=d566ef916e9dedc494f5f793a6690ba5"
LIC_FILES_CHKSUM = "file://package.xml;beginline=18;endline=18;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "curl rosconsole roslib"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz \
file://0001-Python3-compatibility-10.patch \
"
SRC_URI[md5sum] = "1dffd39475ebe70b14390889d3b4b3c4"
SRC_URI[sha256sum] = "5f00e95c5a086973efa25e26da9cee8f4b10b446fbb5eb6694b32b2201539866"
SRC_URI[md5sum] = "cd1055502daeaf93985fb56327c419f4"
SRC_URI[sha256sum] = "db3ce752736123499d80d803526080e31f2ba21460fd135186b26bf7b72fed2a"
S = "${WORKDIR}/${ROS_SP}"

View File

@ -1,7 +1,7 @@
DESCRIPTION = "The Kinematics and Dynamics Library (KDL) defines a tree structure to represent the kinematic and dynamic parameters of a robot mechanism. kdl_parser provides tools to construct a KDL tree from an XML robot representation in URDF."
DESCRIPTION = "kdl_parser provides tools to construct a KDL tree from an XML robot representation in URDF."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=15;endline=15;md5=d566ef916e9dedc494f5f793a6690ba5"
LIC_FILES_CHKSUM = "file://package.xml;beginline=17;endline=17;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "libeigen orocos-kdl rosconsole roscpp urdf cmake-modules"

View File

@ -1,6 +1,6 @@
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "feb4e2d49ba8e4607524d4e91aeec4c9"
SRC_URI[sha256sum] = "6313abe64e29fbbe87d8e108c13ccd075de4ff8f01b85f988716b9475d312112"
SRC_URI[md5sum] = "5867e22cea9db638689102a544010974"
SRC_URI[sha256sum] = "da70be8a4d70737880c98402cc5beee008e617e1e60e46b2b59d598376525c48"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"

View File

@ -1,7 +1,7 @@
DESCRIPTION = "This package contains a C++ base class for URDF parsers"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=d566ef916e9dedc494f5f793a6690ba5"
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "urdfdom-headers"

View File

@ -1,7 +1,7 @@
DESCRIPTION = "This package contains a C++ parser for the Unified Robot Description Format (URDF), which is an XML format for representing a robot model. The code API of the parser has been through our review process and will remain backwards compatible in future releases."
DESCRIPTION = "This package contains a C++ parser for the Unified Robot Description Format (URDF)"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=15;endline=15;md5=d566ef916e9dedc494f5f793a6690ba5"
LIC_FILES_CHKSUM = "file://package.xml;beginline=16;endline=16;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "rosconsole-bridge roscpp urdfdom-headers urdf-parser-plugin pluginlib urdfdom cmake-modules libtinyxml class-loader"