Merge pull request #239 from bulwahn/make-rostest-optional

making rostest optional in most packages
This commit is contained in:
KristofRobot 2014-03-21 15:48:52 +01:00
commit 455385f0f6
31 changed files with 411 additions and 196 deletions

View File

@ -0,0 +1,32 @@
From ee8607f48165af73c23b1210179a88ff1d08e5bf Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Tue, 4 Feb 2014 16:00:25 +0100
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
---
CMakeLists.txt | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9a3652f..16adefe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,7 @@
cmake_minimum_required(VERSION 2.8.3)
project(actionlib)
-find_package(catkin REQUIRED COMPONENTS actionlib_msgs message_generation roscpp rostest rosunit std_msgs)
+find_package(catkin REQUIRED COMPONENTS actionlib_msgs message_generation roscpp rosunit std_msgs)
find_package(Boost REQUIRED COMPONENTS thread)
include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
@@ -34,5 +34,6 @@ install(DIRECTORY include/${PROJECT_NAME}/
FILES_MATCHING PATTERN "*.h")
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
add_subdirectory(test)
endif()
--
1.8.3.2

View File

@ -1,29 +0,0 @@
From 9a6b0ed481e8585d5a042f69c8cdaf39b783fc9a Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sat, 21 Sep 2013 15:41:34 +0200
Subject: [PATCH] rostest is optional
---
CMakeLists.txt | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9a3652f..ab0226c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,11 @@
cmake_minimum_required(VERSION 2.8.3)
project(actionlib)
-find_package(catkin REQUIRED COMPONENTS actionlib_msgs message_generation roscpp rostest rosunit std_msgs)
+if(CATKIN_ENABLE_TESTING)
+ find_package(catkin REQUIRED COMPONENTS actionlib_msgs message_generation roscpp rostest rosunit std_msgs)
+else()
+ find_package(catkin REQUIRED COMPONENTS actionlib_msgs message_generation roscpp std_msgs)
+endif()
find_package(Boost REQUIRED COMPONENTS thread)
include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
--
1.7.10.4

View File

@ -10,6 +10,6 @@ SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilena
SRC_URI[md5sum] = "2e13067c3c85e81a3ab4b603ff15e45b" SRC_URI[md5sum] = "2e13067c3c85e81a3ab4b603ff15e45b"
SRC_URI[sha256sum] = "f71df286552e6bf3a03ef83635342d3bdd6eef836e7b0565dccd2d341dbeaa11" SRC_URI[sha256sum] = "f71df286552e6bf3a03ef83635342d3bdd6eef836e7b0565dccd2d341dbeaa11"
SRC_URI += "file://0001-rostest-is-optional.patch" SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch"
inherit catkin inherit catkin

View File

@ -1,29 +0,0 @@
From 9c9051d1c00164cf2b63e23ad10f24ddce2b0413 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sat, 21 Sep 2013 15:53:17 +0200
Subject: [PATCH] rostest is optional
---
chatter_sender/CMakeLists.txt | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/chatter_sender/CMakeLists.txt b/chatter_sender/CMakeLists.txt
index f2bc563..243bc53 100644
--- a/chatter_sender/CMakeLists.txt
+++ b/chatter_sender/CMakeLists.txt
@@ -1,7 +1,11 @@
cmake_minimum_required(VERSION 2.8.3)
project(chatter_sender)
-find_package(catkin REQUIRED COMPONENTS chatter_msgs roscpp rostest)
+if(CATKIN_ENABLE_TESTING)
+ find_package(catkin REQUIRED COMPONENTS chatter_msgs roscpp rostest)
+else()
+ find_package(catkin REQUIRED COMPONENTS chatter_msgs roscpp)
+endif()
catkin_package()
--
1.7.10.4

View File

@ -6,5 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc
DEPENDS = "chatter-msgs roscpp" DEPENDS = "chatter-msgs roscpp"
require chatter.inc require chatter.inc
SRC_URI += "file://0001-rostest-is-optional.patch;striplevel=2"

View File

@ -1,6 +1,6 @@
SRC_URI = "https://github.com/bmwcarit/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz" SRC_URI = "https://github.com/bmwcarit/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "c26fdc13d96d1b65d0c1e03b41572550" SRC_URI[md5sum] = "3048507b90d31babed579677c73aa219"
SRC_URI[sha256sum] = "b18f8a08fe8bdc4d7a89ee9ab15892348c25d508dad1bed87e795805506f315f" SRC_URI[sha256sum] = "ff7f5a705049bd6e312afcbbf919cc5a382160ff6eca8571a7dec4f4e0bc8f15"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}" S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"

View File

@ -1,5 +1,15 @@
From f953151cce932ffa8e0d14fc12b512d8e7d448fe Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Wed, 22 Jan 2014 11:18:25 +0100
Subject: [PATCH] check for CATKIN_ENABLE_TESTING
---
CMakeLists.txt | 8 +++++---
package.xml | 2 +-
2 files changed, 6 insertions(+), 4 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7e73a89..60c4bff 100644 index cdf4a9f..a76b054 100644
--- a/CMakeLists.txt --- a/CMakeLists.txt
+++ b/CMakeLists.txt +++ b/CMakeLists.txt
@@ -30,9 +30,11 @@ target_link_libraries(DepthImageToLaserScanNodelet DepthImageToLaserScanROS ${ca @@ -30,9 +30,11 @@ target_link_libraries(DepthImageToLaserScanNodelet DepthImageToLaserScanROS ${ca
@ -17,3 +27,19 @@ index 7e73a89..60c4bff 100644
# add the test executable, keep it from being built by "make all" # add the test executable, keep it from being built by "make all"
add_executable(test_dtl EXCLUDE_FROM_ALL test/depthimage_to_laserscan_rostest.cpp) add_executable(test_dtl EXCLUDE_FROM_ALL test/depthimage_to_laserscan_rostest.cpp)
diff --git a/package.xml b/package.xml
index 86f182a..d5ecc06 100644
--- a/package.xml
+++ b/package.xml
@@ -12,7 +12,7 @@
<author>Chad Rockey</author>
- <buildtool_depend>catkin</buildtool_depend>
+ <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
<build_depend>roscpp</build_depend>
<build_depend>gtest</build_depend>
--
1.8.5.1

View File

@ -0,0 +1,33 @@
From 5aef0d6619394df17bffe743071295ad041b5794 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Tue, 4 Feb 2014 16:02:09 +0100
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
---
CMakeLists.txt | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ccb54f9..97eea51 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,7 +5,7 @@ project(filters)
# Find dependencies
##############################################################################
-find_package(catkin REQUIRED COMPONENTS pluginlib roslib roscpp rosconsole rostest)
+find_package(catkin REQUIRED COMPONENTS pluginlib roslib roscpp rosconsole)
find_package(Boost COMPONENTS system filesystem thread REQUIRED)
include_directories(
@@ -41,6 +41,7 @@ add_library(transfer_function src/transfer_function.cpp)
target_link_libraries(transfer_function ${catkin_LIBRARIES} ${Boost_LIBRARIES})
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
# Test median filter
add_executable(median_test EXCLUDE_FROM_ALL test/test_median.cpp )
target_link_libraries(median_test median ${catkin_LIBRARIES} ${Boost_LIBRARIES} ${GTEST_LIBRARIES})
--
1.8.3.2

View File

@ -3,12 +3,13 @@ SECTION = "devel"
LICENSE = "BSD" LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9dedc494f5f793a6690ba5" LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "roslib rosconsole roscpp pluginlib rostest" DEPENDS = "roslib rosconsole roscpp pluginlib"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz" SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "0dd26504be16afa7816e9a5aa11715f1" SRC_URI[md5sum] = "0dd26504be16afa7816e9a5aa11715f1"
SRC_URI[sha256sum] = "fb71f1fbeaf89726877fce66dce1db8957c5cc6dffa1973d6a104a10233f8237" SRC_URI[sha256sum] = "fb71f1fbeaf89726877fce66dce1db8957c5cc6dffa1973d6a104a10233f8237"
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch" SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch; \
file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch"
inherit catkin inherit catkin

View File

@ -0,0 +1,34 @@
From 18e81e33c052e26ae60259708095a2a933f75fd1 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Tue, 4 Feb 2014 16:02:48 +0100
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
---
tf/CMakeLists.txt | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/tf/CMakeLists.txt b/tf/CMakeLists.txt
index fa4a42f..c6988e1 100644
--- a/tf/CMakeLists.txt
+++ b/tf/CMakeLists.txt
@@ -4,7 +4,7 @@ project(tf)
find_package(catkin REQUIRED)
find_package(Boost REQUIRED thread signals)
-find_package(catkin REQUIRED angles geometry_msgs message_filters message_generation rosconsole roscpp rostest rostime sensor_msgs std_msgs tf2_ros)
+find_package(catkin REQUIRED angles geometry_msgs message_filters message_generation rosconsole roscpp rostime sensor_msgs std_msgs tf2_ros)
catkin_python_setup()
@@ -48,6 +48,8 @@ target_link_libraries(static_transform_publisher ${PROJECT_NAME})
# Tests
if(CATKIN_ENABLE_TESTING)
+find_package(rostest)
+
catkin_add_gtest(tf_unittest test/tf_unittest.cpp)
target_link_libraries(tf_unittest ${PROJECT_NAME})
--
1.8.3.2

View File

@ -1,30 +0,0 @@
From 9f1e801c6de00287658f1bae21048f37bb9bb198 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sat, 21 Sep 2013 16:13:16 +0200
Subject: [PATCH] rostest is optional
---
tf/CMakeLists.txt | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/tf/CMakeLists.txt b/tf/CMakeLists.txt
index e8d3044..2d36df3 100644
--- a/tf/CMakeLists.txt
+++ b/tf/CMakeLists.txt
@@ -4,7 +4,12 @@ project(tf)
find_package(catkin REQUIRED)
find_package(Boost REQUIRED thread signals)
-find_package(catkin REQUIRED angles geometry_msgs message_filters message_generation rosconsole roscpp rostest rostime sensor_msgs std_msgs tf2_ros)
+
+if(CATKIN_ENABLE_TESTING)
+ find_package(catkin REQUIRED angles geometry_msgs message_filters message_generation rosconsole roscpp rostest rostime sensor_msgs std_msgs tf2_ros)
+else()
+ find_package(catkin REQUIRED angles geometry_msgs message_filters message_generation rosconsole roscpp rostime sensor_msgs std_msgs tf2_ros)
+endif()
catkin_python_setup()
--
1.7.10.4

View File

@ -7,6 +7,6 @@ DEPENDS = "angles geometry-msgs message-filters sensor-msgs tf2-ros"
require geometry.inc require geometry.inc
SRC_URI += "file://0001-rostest-is-optional.patch;striplevel=2" SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;striplevel=2"
RDEPENDS_${PN} = "python-numpy" RDEPENDS_${PN} = "python-numpy"

View File

@ -0,0 +1,33 @@
From 29f5630047052c24f1b506bdb743ebd53358686d Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Tue, 4 Feb 2014 16:04:23 +0100
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
---
camera_info_manager/CMakeLists.txt | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/camera_info_manager/CMakeLists.txt b/camera_info_manager/CMakeLists.txt
index f220861..8b83216 100644
--- a/camera_info_manager/CMakeLists.txt
+++ b/camera_info_manager/CMakeLists.txt
@@ -10,7 +10,7 @@ catkin_package(INCLUDE_DIRS include
DEPENDS Boost roscpp sensor_msgs
)
-find_package(catkin COMPONENTS camera_calibration_parsers image_transport roscpp roslib rostest)
+find_package(catkin COMPONENTS camera_calibration_parsers image_transport roscpp roslib)
include_directories(SYSTEM ${camera_calibration_parsers_INCLUDE_DIRS}
${image_transport_INCLUDE_DIRS}
@@ -34,6 +34,7 @@ install(DIRECTORY include/${PROJECT_NAME}/
)
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
# Unit test uses gtest, but needs rostest to create a ROS environment.
# Hence, it must be created as a normal executable, not using
# catkin_add_gtest() which runs an additional test without rostest.
--
1.8.3.2

View File

@ -3,6 +3,8 @@ SECTION = "devel"
LICENSE = "BSD" LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=15;endline=15;md5=d566ef916e9dedc494f5f793a6690ba5" LIC_FILES_CHKSUM = "file://package.xml;beginline=15;endline=15;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "boost camera-calibration-parsers image-transport roscpp roslib rostest sensor-msgs" DEPENDS = "boost camera-calibration-parsers image-transport roscpp roslib sensor-msgs"
require image-common.inc require image-common.inc
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;striplevel=2"

View File

@ -3,6 +3,6 @@ SECTION = "devel"
LICENSE = "LGPL" LICENSE = "LGPL"
LIC_FILES_CHKSUM = "file://package.xml;beginline=20;endline=20;md5=58d727014cda5ed405b7fb52666a1f97" LIC_FILES_CHKSUM = "file://package.xml;beginline=20;endline=20;md5=58d727014cda5ed405b7fb52666a1f97"
DEPENDS = "dynamic-reconfigure message-filters nav-msgs roscpp rostest std-srvs tf" DEPENDS = "dynamic-reconfigure message-filters nav-msgs roscpp std-srvs tf"
require navigation.inc require navigation.inc

View File

@ -7,7 +7,7 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=18;endline=18;md5=01c2bc31767ccb3a68e12f02612b2a97" LIC_FILES_CHKSUM = "file://package.xml;beginline=18;endline=18;md5=01c2bc31767ccb3a68e12f02612b2a97"
DEPENDS = "dynamic-reconfigure geometry-msgs laser-geometry map-msgs message-filters \ DEPENDS = "dynamic-reconfigure geometry-msgs laser-geometry map-msgs message-filters \
message-generation nav-msgs pcl-conversions pcl-ros pluginlib roscpp rostest \ message-generation nav-msgs pcl-conversions pcl-ros pluginlib roscpp \
sensor-msgs std-msgs tf visualization-msgs voxel-grid" sensor-msgs std-msgs tf visualization-msgs voxel-grid"
require navigation.inc require navigation.inc

View File

@ -0,0 +1,54 @@
From 9fdd83868742a5f00406632d7c7084a4fc272c35 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Tue, 4 Feb 2014 16:05:31 +0100
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
---
map_server/CMakeLists.txt | 2 +-
robot_pose_ekf/CMakeLists.txt | 3 ++-
2 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/map_server/CMakeLists.txt b/map_server/CMakeLists.txt
index 40be4cc..c2bff5f 100644
--- a/map_server/CMakeLists.txt
+++ b/map_server/CMakeLists.txt
@@ -6,7 +6,6 @@ find_package(catkin REQUIRED
roscpp
tf
nav_msgs
- rostest
)
find_package(Boost REQUIRED COMPONENTS system)
@@ -55,6 +54,7 @@ endfunction()
## Tests
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
copy_test_data( FILES
test/testmap.bmp
test/testmap.png )
diff --git a/robot_pose_ekf/CMakeLists.txt b/robot_pose_ekf/CMakeLists.txt
index c6d6ff0..bd51164 100644
--- a/robot_pose_ekf/CMakeLists.txt
+++ b/robot_pose_ekf/CMakeLists.txt
@@ -23,7 +23,6 @@ link_directories(${BFL_LIBRARY_DIRS})
find_package(catkin REQUIRED
COMPONENTS
roscpp
- rostest
tf
nav_msgs
std_msgs
@@ -79,6 +78,8 @@ include(CMakeDetermineSystem)
if(CMAKE_SYSTEM_NAME MATCHES "Linux")
if(CATKIN_ENABLE_TESTING)
+find_package(rostest)
+
catkin_download_test_data(download_data_ekf_test2_indexed.bag http://download.ros.org/data/robot_pose_ekf/ekf_test2_indexed.bag FILENAME test/ekf_test2.bag MD5 71addef0ed900e05b301e0b4fdca99e2)
add_executable(test_robot_pose_ekf test/test_robot_pose_ekf.cpp)
target_link_libraries(test_robot_pose_ekf
--
1.8.3.2

View File

@ -3,6 +3,6 @@ SECTION = "devel"
LICENSE = "BSD" LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=01c2bc31767ccb3a68e12f02612b2a97" LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=01c2bc31767ccb3a68e12f02612b2a97"
DEPENDS = "libsdl-image nav-msgs roscpp rostest tf yaml-cpp" DEPENDS = "libsdl-image nav-msgs roscpp tf yaml-cpp"
require navigation.inc require navigation.inc

View File

@ -2,6 +2,8 @@ SRC_URI = "https://github.com/ros-planning/${ROS_SPN}/archive/${PV}.tar.gz;downl
SRC_URI[md5sum] = "f6dd416880d0e92985be5268699d9cb8" SRC_URI[md5sum] = "f6dd416880d0e92985be5268699d9cb8"
SRC_URI[sha256sum] = "52d88c64047539f3d7552cee48def65f082e39d37221659b2533aecef429bb42" SRC_URI[sha256sum] = "52d88c64047539f3d7552cee48def65f082e39d37221659b2533aecef429bb42"
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;patchdir=.."
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}" S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
inherit catkin inherit catkin

View File

@ -0,0 +1,88 @@
From 560ce8a8855a43565d1798af19cc943c61a72e7f Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Tue, 4 Feb 2014 12:57:23 +0100
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
---
tools/rosnode/CMakeLists.txt | 3 ++-
tools/rostopic/CMakeLists.txt | 3 ++-
tools/topic_tools/CMakeLists.txt | 3 ++-
utilities/roswtf/CMakeLists.txt | 3 ++-
4 files changed, 8 insertions(+), 4 deletions(-)
diff --git a/tools/rosnode/CMakeLists.txt b/tools/rosnode/CMakeLists.txt
index a7347b4..f305890 100644
--- a/tools/rosnode/CMakeLists.txt
+++ b/tools/rosnode/CMakeLists.txt
@@ -1,10 +1,11 @@
cmake_minimum_required(VERSION 2.8.3)
project(rosnode)
-find_package(catkin REQUIRED COMPONENTS rostest)
+find_package(catkin REQUIRED)
catkin_package()
catkin_python_setup()
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
add_rostest(test/rosnode.test)
endif()
diff --git a/tools/rostopic/CMakeLists.txt b/tools/rostopic/CMakeLists.txt
index 0551583..db7917b 100644
--- a/tools/rostopic/CMakeLists.txt
+++ b/tools/rostopic/CMakeLists.txt
@@ -1,6 +1,6 @@
cmake_minimum_required(VERSION 2.8.3)
project(rostopic)
-find_package(catkin REQUIRED COMPONENTS rostest)
+find_package(catkin REQUIRED)
catkin_package()
catkin_python_setup()
@@ -9,5 +9,6 @@ install(PROGRAMS scripts/rostopic
DESTINATION ${CATKIN_PACKAGE_BIN_DESTINATION})
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
add_rostest(test/rostopic.test)
endif()
diff --git a/tools/topic_tools/CMakeLists.txt b/tools/topic_tools/CMakeLists.txt
index e441b9a..2d52451 100644
--- a/tools/topic_tools/CMakeLists.txt
+++ b/tools/topic_tools/CMakeLists.txt
@@ -1,6 +1,6 @@
cmake_minimum_required(VERSION 2.8.3)
project(topic_tools)
-find_package(catkin COMPONENTS cpp_common message_generation rosconsole roscpp rostest rostime rosunit std_msgs xmlrpcpp)
+find_package(catkin COMPONENTS cpp_common message_generation rosconsole roscpp rostime std_msgs xmlrpcpp)
include_directories(include)
include_directories(${catkin_INCLUDE_DIRS})
@@ -62,6 +62,7 @@ install(PROGRAMS
#Testing
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest rosunit)
catkin_add_gtest(${PROJECT_NAME}-utest test/utest.cpp)
if(TARGET ${PROJECT_NAME}-utest)
target_link_libraries(${PROJECT_NAME}-utest topic_tools)
diff --git a/utilities/roswtf/CMakeLists.txt b/utilities/roswtf/CMakeLists.txt
index dccb342..97a34ff 100644
--- a/utilities/roswtf/CMakeLists.txt
+++ b/utilities/roswtf/CMakeLists.txt
@@ -1,10 +1,11 @@
cmake_minimum_required(VERSION 2.8.3)
project(roswtf)
-find_package(catkin REQUIRED COMPONENTS rostest)
+find_package(catkin REQUIRED)
catkin_package()
catkin_python_setup()
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
add_rostest(test/roswtf.test)
catkin_add_nosetests(test)
endif()
--
1.8.3.2

View File

@ -1,62 +0,0 @@
From 0f16232f1bac7d03cce598bd305bcdd4c456f4ed Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sat, 21 Sep 2013 15:20:11 +0200
Subject: [PATCH] rostest is optional
---
tools/rosnode/CMakeLists.txt | 6 +++++-
tools/rostopic/CMakeLists.txt | 6 +++++-
utilities/roswtf/CMakeLists.txt | 6 +++++-
3 files changed, 15 insertions(+), 3 deletions(-)
diff --git a/tools/rosnode/CMakeLists.txt b/tools/rosnode/CMakeLists.txt
index a7347b4..b397106 100644
--- a/tools/rosnode/CMakeLists.txt
+++ b/tools/rosnode/CMakeLists.txt
@@ -1,6 +1,10 @@
cmake_minimum_required(VERSION 2.8.3)
project(rosnode)
-find_package(catkin REQUIRED COMPONENTS rostest)
+if(CATKIN_ENABLE_TESTING)
+ find_package(catkin REQUIRED COMPONENTS rostest)
+else()
+ find_package(catkin REQUIRED)
+endif()
catkin_package()
catkin_python_setup()
diff --git a/tools/rostopic/CMakeLists.txt b/tools/rostopic/CMakeLists.txt
index 0551583..24fbed0 100644
--- a/tools/rostopic/CMakeLists.txt
+++ b/tools/rostopic/CMakeLists.txt
@@ -1,6 +1,10 @@
cmake_minimum_required(VERSION 2.8.3)
project(rostopic)
-find_package(catkin REQUIRED COMPONENTS rostest)
+if(CATKIN_ENABLE_TESTING)
+ find_package(catkin REQUIRED COMPONENTS rostest)
+else()
+ find_package(catkin REQUIRED)
+endif()
catkin_package()
catkin_python_setup()
diff --git a/utilities/roswtf/CMakeLists.txt b/utilities/roswtf/CMakeLists.txt
index dccb342..cfd0c11 100644
--- a/utilities/roswtf/CMakeLists.txt
+++ b/utilities/roswtf/CMakeLists.txt
@@ -1,6 +1,10 @@
cmake_minimum_required(VERSION 2.8.3)
project(roswtf)
-find_package(catkin REQUIRED COMPONENTS rostest)
+if(CATKIN_ENABLE_TESTING)
+ find_package(catkin REQUIRED COMPONENTS rostest)
+else()
+ find_package(catkin REQUIRED)
+endif()
catkin_package()
catkin_python_setup()
--
1.7.10.4

View File

@ -2,7 +2,7 @@ SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilena
SRC_URI[md5sum] = "f561ebda19fa6e737d5f06e49e925be4" SRC_URI[md5sum] = "f561ebda19fa6e737d5f06e49e925be4"
SRC_URI[sha256sum] = "3572418e3149b54493770695e5241584f5daf9e849ab70007b16d4ce848d7e12" SRC_URI[sha256sum] = "3572418e3149b54493770695e5241584f5daf9e849ab70007b16d4ce848d7e12"
SRC_URI += "file://0001-rostest-is-optional.patch;patchdir=../.." SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;patchdir=../.."
ROS_PKG_SUBDIR ?= "" ROS_PKG_SUBDIR ?= ""
S = "${WORKDIR}/${ROS_SP}/${ROS_PKG_SUBDIR}/${ROS_BPN}" S = "${WORKDIR}/${ROS_SP}/${ROS_PKG_SUBDIR}/${ROS_BPN}"

View File

@ -3,6 +3,6 @@ SECTION = "devel"
LICENSE = "BSD" LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5" LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "rostest control-toolbox controller-interface controller-manager" DEPENDS = "control-toolbox controller-interface controller-manager"
require ros-control.inc require ros-control.inc

View File

@ -0,0 +1,56 @@
From b746072f9729b9d39a5e1901c0ffa7dcb5f19956 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Tue, 4 Feb 2014 16:06:33 +0100
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
---
controller_manager_tests/CMakeLists.txt | 3 ++-
joint_limits_interface/CMakeLists.txt | 4 +++-
2 files changed, 5 insertions(+), 2 deletions(-)
diff --git a/controller_manager_tests/CMakeLists.txt b/controller_manager_tests/CMakeLists.txt
index 95c73cc..9e018b1 100644
--- a/controller_manager_tests/CMakeLists.txt
+++ b/controller_manager_tests/CMakeLists.txt
@@ -29,7 +29,7 @@ if(USE_ROSBUILD)
else()
# Load catkin and all dependencies required for this package
- find_package(catkin REQUIRED COMPONENTS rostest controller_manager controller_interface control_toolbox)
+ find_package(catkin REQUIRED COMPONENTS controller_manager controller_interface control_toolbox)
include_directories(include ${Boost_INCLUDE_DIR} ${catkin_INCLUDE_DIRS})
@@ -53,6 +53,7 @@ else()
target_link_libraries(dummy_app ${PROJECT_NAME} ${catkin_LIBRARIES})
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
add_executable(cm_test test/cm_test.cpp)
add_dependencies(tests cm_test)
target_link_libraries(cm_test ${GTEST_LIBRARIES} ${catkin_LIBRARIES})
diff --git a/joint_limits_interface/CMakeLists.txt b/joint_limits_interface/CMakeLists.txt
index 16644a2..7053abc 100644
--- a/joint_limits_interface/CMakeLists.txt
+++ b/joint_limits_interface/CMakeLists.txt
@@ -23,7 +23,7 @@ if(USE_ROSBUILD)
else() # catkin
- find_package(catkin REQUIRED COMPONENTS roscpp rostest)
+ find_package(catkin REQUIRED COMPONENTS roscpp)
include_directories(
SYSTEM
@@ -44,6 +44,8 @@ else() # catkin
)
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
+
catkin_add_gtest(joint_limits_interface_test test/joint_limits_interface_test.cpp)
target_link_libraries(joint_limits_interface_test ${catkin_LIBRARIES})
--
1.8.3.2

View File

@ -3,6 +3,6 @@ SECTION = "devel"
LICENSE = "BSD" LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=6;endline=6;md5=d566ef916e9dedc494f5f793a6690ba5" LIC_FILES_CHKSUM = "file://package.xml;beginline=6;endline=6;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "rostest roscpp hardware-interface urdfdom" DEPENDS = "roscpp hardware-interface urdfdom"
require ros-control.inc require ros-control.inc

View File

@ -2,6 +2,8 @@ SRC_URI = "https://github.com/ros-controls/${ROS_SPN}/archive/${PV}.tar.gz;downl
SRC_URI[md5sum] = "f3fa5aabaa68f4f23bb277f47746cfc4" SRC_URI[md5sum] = "f3fa5aabaa68f4f23bb277f47746cfc4"
SRC_URI[sha256sum] = "598d6c28148764f328b87ef0c2533e49f9b4925a1457688f2715ce332fc82dfd" SRC_URI[sha256sum] = "598d6c28148764f328b87ef0c2533e49f9b4925a1457688f2715ce332fc82dfd"
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;patchdir=.."
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}" S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
inherit catkin inherit catkin

View File

@ -0,0 +1,33 @@
From 8e1fdde288fe2f1edb20e504846dabac026ca2ff Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Tue, 4 Feb 2014 16:07:10 +0100
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
---
rospy_tutorials/CMakeLists.txt | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/rospy_tutorials/CMakeLists.txt b/rospy_tutorials/CMakeLists.txt
index b588dfc..5287af3 100644
--- a/rospy_tutorials/CMakeLists.txt
+++ b/rospy_tutorials/CMakeLists.txt
@@ -1,7 +1,7 @@
cmake_minimum_required(VERSION 2.8.3)
project(rospy_tutorials)
-find_package(catkin REQUIRED COMPONENTS message_generation rostest std_msgs)
+find_package(catkin REQUIRED COMPONENTS message_generation std_msgs)
add_message_files(DIRECTORY msg FILES Floats.msg HeaderString.msg)
add_service_files(DIRECTORY srv FILES AddTwoInts.srv BadTwoInts.srv)
@@ -27,6 +27,7 @@ foreach(T
endforeach()
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
foreach(T
test/test-add-two-ints.launch
test/test-peer-subscribe-notify.launch
--
1.8.3.2

View File

@ -1,29 +0,0 @@
From 3eaf40260ea400cb779ca229cbf3ab27f5a2b6eb Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sat, 21 Sep 2013 16:33:11 +0200
Subject: [PATCH] rostest is optional
---
rospy_tutorials/CMakeLists.txt | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/rospy_tutorials/CMakeLists.txt b/rospy_tutorials/CMakeLists.txt
index b588dfc..a48ec0d 100644
--- a/rospy_tutorials/CMakeLists.txt
+++ b/rospy_tutorials/CMakeLists.txt
@@ -1,7 +1,11 @@
cmake_minimum_required(VERSION 2.8.3)
project(rospy_tutorials)
-find_package(catkin REQUIRED COMPONENTS message_generation rostest std_msgs)
+if(CATKIN_ENABLE_TESTING)
+ find_package(catkin REQUIRED COMPONENTS message_generation rostest std_msgs)
+else()
+ find_package(catkin REQUIRED COMPONENTS message_generation std_msgs)
+endif()
add_message_files(DIRECTORY msg FILES Floats.msg HeaderString.msg)
add_service_files(DIRECTORY srv FILES AddTwoInts.srv BadTwoInts.srv)
--
1.7.10.4

View File

@ -7,4 +7,4 @@ DEPENDS = "message-generation std-msgs cpp-common roscpp-serialization"
require ros-tutorials.inc require ros-tutorials.inc
SRC_URI += "file://0001-rostest-is-optional.patch;striplevel=2" SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;striplevel=2"