Revert "DRAFT [morty] cv-bridge-2.1.0.inc: fix configure error"
This reverts commit 7a28f07d3a722fb148bbd7f136eb838dc57f7101.
This commit is contained in:
parent
4873f60888
commit
53021ac3a0
|
@ -9,7 +9,4 @@ ROS_BUILDTOOL_DEPENDS += " \
|
||||||
|
|
||||||
# This option disables python2 support because we can't support both python2
|
# This option disables python2 support because we can't support both python2
|
||||||
# and python3 since OE upstream has disabled python2 bindings in Boost.
|
# and python3 since OE upstream has disabled python2 bindings in Boost.
|
||||||
EXTRA_OECMAKE =+ "${@'-DANDROID=ON' if d.getVar('PYTHON_PN', True) != 'python3' else ''}"
|
EXTRA_OECMAKE =+ "${@'-DANDROID=ON' if d.getVar('PYTHON_PN') != 'python3' else ''}"
|
||||||
|
|
||||||
FILESEXTRAPATHS_prepend := "${THISDIR}/cv-bridge:"
|
|
||||||
SRC_URI_append = " file://0001-Fix-configure-error-for-python.patch"
|
|
||||||
|
|
|
@ -1,25 +0,0 @@
|
||||||
From 755d544da685e97fcaa60f536838eeff194d6432 Mon Sep 17 00:00:00 2001
|
|
||||||
From: JeongBong Seo <jb.seo@lge.com>
|
|
||||||
Date: Wed, 3 Apr 2019 22:28:40 +0900
|
|
||||||
Subject: Fix configure error for python
|
|
||||||
|
|
||||||
---
|
|
||||||
CMakeLists.txt | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
||||||
index d93e3d2..0d162a0 100644
|
|
||||||
--- a/CMakeLists.txt
|
|
||||||
+++ b/CMakeLists.txt
|
|
||||||
@@ -21,7 +21,7 @@ if(NOT ANDROID)
|
|
||||||
if(Boost_VERSION LESS 106500)
|
|
||||||
find_package(Boost REQUIRED python)
|
|
||||||
else()
|
|
||||||
- find_package(Boost REQUIRED python3)
|
|
||||||
+ find_package(Boost REQUIRED python35)
|
|
||||||
endif()
|
|
||||||
endif()
|
|
||||||
else()
|
|
||||||
--
|
|
||||||
2.17.1
|
|
||||||
|
|
Loading…
Reference in New Issue