pcl: updating to 1.8.0
Due to the update to 1.8.0, the upstream-accepted patch is not anymore needed to be applied. Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
This commit is contained in:
parent
36adf9b100
commit
5a8551ca64
|
@ -1,38 +0,0 @@
|
|||
From 1361899d1a336938811eceb17e2f71abe650ae17 Mon Sep 17 00:00:00 2001
|
||||
From: Davide Viti <zinosat@tiscali.it>
|
||||
Date: Sun, 9 Nov 2014 21:37:28 +0100
|
||||
Subject: [PATCH] Add "WITH_OPENGL" option to make OpenGL and Glut inclusion
|
||||
conditional
|
||||
|
||||
Upstream-Status: Accepted
|
||||
|
||||
This patch file was created from the pcl repository with:
|
||||
|
||||
`git checkout 1361899d1a336938811eceb17e2f71abe650ae17 && git format-patch -1`
|
||||
|
||||
I expect this patch to be dropped in any recipe version later than 1.7.2.
|
||||
|
||||
Signed-off-by: Lukas.Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
---
|
||||
CMakeLists.txt | 5 ++++-
|
||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 6cc473d..7fda151 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -403,7 +403,10 @@ if(WITH_PCAP)
|
||||
endif(WITH_PCAP)
|
||||
|
||||
# OpenGL and GLUT
|
||||
-include("${PCL_SOURCE_DIR}/cmake/pcl_find_gl.cmake")
|
||||
+option(WITH_OPENGL "Support for OpenGL" TRUE)
|
||||
+if(WITH_OPENGL)
|
||||
+ include("${PCL_SOURCE_DIR}/cmake/pcl_find_gl.cmake")
|
||||
+endif(WITH_OPENGL)
|
||||
|
||||
### ---[ Create the config.h file
|
||||
set(pcl_config_h_in "${CMAKE_CURRENT_SOURCE_DIR}/pcl_config.h.in")
|
||||
--
|
||||
2.4.3
|
||||
|
|
@ -6,10 +6,8 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5b8a2a1aa14e6de44b4273134946a34c"
|
|||
DEPENDS = "boost libflann libeigen qhull"
|
||||
|
||||
SRC_URI = "https://github.com/PointCloudLibrary/${PN}/archive/${P}.tar.gz"
|
||||
SRC_URI[md5sum] = "02c72eb6760fcb1f2e359ad8871b9968"
|
||||
SRC_URI[sha256sum] = "479f84f2c658a6319b78271111251b4c2d6cf07643421b66bbc351d9bed0ae93"
|
||||
|
||||
SRC_URI += "file://0001-Add-WITH_OPENGL-option-to-make-OpenGL-and-Glut-inclu.patch"
|
||||
SRC_URI[md5sum] = "8c1308be2c13106e237e4a4204a32cca"
|
||||
SRC_URI[sha256sum] = "9e54b0c1b59a67a386b9b0f4acb2d764272ff9a0377b825c4ed5eedf46ebfcf4"
|
||||
|
||||
S = "${WORKDIR}/pcl-${P}"
|
||||
|
||||
|
@ -19,6 +17,7 @@ EXTRA_OECMAKE += "\
|
|||
-DHAVE_POSIX_MEMALIGN_EXITCODE=0 \
|
||||
${@bb.utils.contains("TARGET_CC_ARCH", "-msse4.2", "-DHAVE_SSE4_2_EXTENSIONS_EXITCODE=0", "-DHAVE_SSE4_2_EXTENSIONS_EXITCODE=1", d)} \
|
||||
${@bb.utils.contains("TARGET_CC_ARCH", "-msse4.1", "-DHAVE_SSE4_1_EXTENSIONS_EXITCODE=0", "-DHAVE_SSE4_1_EXTENSIONS_EXITCODE=1", d)} \
|
||||
-DHAVE_SSSE3_EXTENSIONS_EXITCODE=0 \
|
||||
${@bb.utils.contains("TARGET_CC_ARCH", "-msse3", "-DHAVE_SSE3_EXTENSIONS_EXITCODE=0", "-DHAVE_SSE3_EXTENSIONS_EXITCODE=1", d)} \
|
||||
${@bb.utils.contains("TARGET_CC_ARCH", "-msse2", "-DHAVE_SSE2_EXTENSIONS_EXITCODE=0", "-DHAVE_SSE2_EXTENSIONS_EXITCODE=1", d)} \
|
||||
${@bb.utils.contains("TARGET_CC_ARCH", "-msse", "-DHAVE_SSE_EXTENSIONS_EXITCODE=0", "-DHAVE_SSE_EXTENSIONS_EXITCODE=1", d)} \
|
||||
|
@ -37,4 +36,4 @@ CXXFLAGS += "${@bb.utils.contains("TARGET_CC_ARCH", "-mfpmath=sse", "", "-ffloat
|
|||
|
||||
inherit cmake
|
||||
|
||||
FILES_${PN}-dev += "${datadir}/${PN}-1.7/*.cmake"
|
||||
FILES_${PN}-dev += "${datadir}/${PN}-1.8/*.cmake"
|
Loading…
Reference in New Issue