actionlib: updating to 1.11.3
The patch provided upstream is accepted since 1.11.2 and hence is removed.
This commit is contained in:
parent
20d4c5f0e9
commit
7a3c4e1707
|
@ -1,33 +0,0 @@
|
|||
From ee8607f48165af73c23b1210179a88ff1d08e5bf Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
Date: Tue, 4 Feb 2014 16:00:25 +0100
|
||||
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
|
||||
|
||||
Upstream-Status: Backport [Accepted in indigo-devel branch]
|
||||
---
|
||||
CMakeLists.txt | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 9a3652f..16adefe 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -1,7 +1,7 @@
|
||||
cmake_minimum_required(VERSION 2.8.3)
|
||||
project(actionlib)
|
||||
|
||||
-find_package(catkin REQUIRED COMPONENTS actionlib_msgs message_generation roscpp rostest rosunit std_msgs)
|
||||
+find_package(catkin REQUIRED COMPONENTS actionlib_msgs message_generation roscpp rosunit std_msgs)
|
||||
find_package(Boost REQUIRED COMPONENTS thread)
|
||||
|
||||
include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
|
||||
@@ -34,5 +34,6 @@ install(DIRECTORY include/${PROJECT_NAME}/
|
||||
FILES_MATCHING PATTERN "*.h")
|
||||
|
||||
if(CATKIN_ENABLE_TESTING)
|
||||
+ find_package(rostest)
|
||||
add_subdirectory(test)
|
||||
endif()
|
||||
--
|
||||
1.8.3.2
|
||||
|
|
@ -7,9 +7,7 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9de
|
|||
DEPENDS = "actionlib-msgs roscpp"
|
||||
|
||||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "2e13067c3c85e81a3ab4b603ff15e45b"
|
||||
SRC_URI[sha256sum] = "f71df286552e6bf3a03ef83635342d3bdd6eef836e7b0565dccd2d341dbeaa11"
|
||||
|
||||
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch"
|
||||
SRC_URI[md5sum] = "d7b1b2b5cac0e1177171a56cc1e7187a"
|
||||
SRC_URI[sha256sum] = "69f12ecb01b33a992d343c6fb306d678ea61bffda796e0648cd72085793ded32"
|
||||
|
||||
inherit catkin
|
Loading…
Reference in New Issue