gmapping: updating to 1.3.9
This commit also adjusts the dependencies, and drops the patch file that is included in this version. Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
This commit is contained in:
parent
b579fb74be
commit
8d686fc130
|
@ -1,36 +0,0 @@
|
||||||
From 52605268cc37e6e765b2168f41c77d430dde7e51 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
|
||||||
Date: Mon, 3 Apr 2017 17:44:07 +0200
|
|
||||||
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
|
|
||||||
|
|
||||||
Upstream-Status: Accepted [https://github.com/ros-perception/slam_gmapping/commit/52605268cc37e6e765b2168f41c77d430dde7e51]
|
|
||||||
|
|
||||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
|
||||||
---
|
|
||||||
gmapping/CMakeLists.txt | 3 ++-
|
|
||||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/gmapping/CMakeLists.txt b/gmapping/CMakeLists.txt
|
|
||||||
index 209d4f3..42388fa 100644
|
|
||||||
--- a/gmapping/CMakeLists.txt
|
|
||||||
+++ b/gmapping/CMakeLists.txt
|
|
||||||
@@ -1,7 +1,7 @@
|
|
||||||
cmake_minimum_required(VERSION 2.8)
|
|
||||||
project(gmapping)
|
|
||||||
|
|
||||||
-find_package(catkin REQUIRED nav_msgs openslam_gmapping roscpp rostest tf rosbag_storage)
|
|
||||||
+find_package(catkin REQUIRED nav_msgs openslam_gmapping roscpp tf rosbag_storage)
|
|
||||||
|
|
||||||
find_package(Boost REQUIRED signals)
|
|
||||||
|
|
||||||
@@ -33,6 +33,7 @@ install(TARGETS slam_gmapping slam_gmapping_replay
|
|
||||||
)
|
|
||||||
|
|
||||||
if(CATKIN_ENABLE_TESTING)
|
|
||||||
+ find_package(rostest REQUIRED)
|
|
||||||
if(TARGET tests)
|
|
||||||
add_executable(gmapping-rtest EXCLUDE_FROM_ALL test/rtest.cpp)
|
|
||||||
target_link_libraries(gmapping-rtest ${catkin_LIBRARIES} ${GTEST_LIBRARIES})
|
|
||||||
--
|
|
||||||
2.5.5
|
|
||||||
|
|
|
@ -3,13 +3,11 @@ SECTION = "devel"
|
||||||
LICENSE = "CC-BY-NC-SA-2.0"
|
LICENSE = "CC-BY-NC-SA-2.0"
|
||||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=11e24f757f025b2cbebd5b14b4a7ca19"
|
LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=11e24f757f025b2cbebd5b14b4a7ca19"
|
||||||
|
|
||||||
DEPENDS = "nav-msgs openslam-gmapping roscpp tf rosbag-storage"
|
DEPENDS = "nodelet nav-msgs openslam-gmapping roscpp tf rosbag-storage"
|
||||||
|
|
||||||
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||||
SRC_URI[md5sum] = "e0735400fdf9353665361eb232a6aa4a"
|
SRC_URI[md5sum] = "2a17fa7818b8f6b23ccd66786c1854ff"
|
||||||
SRC_URI[sha256sum] = "027e31fbe6d8768a746b0eeb93238459b295b15efc0f43f9410afc57d71385d1"
|
SRC_URI[sha256sum] = "5dfd3dc967d8861b820d5ab7355024c3f1626c3fa7b422cf93a85e292ed4d04a"
|
||||||
|
|
||||||
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;striplevel=2"
|
|
||||||
|
|
||||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||||
|
|
Loading…
Reference in New Issue