executive-smach: updating to 2.0.1
Due to the update, this commit drops the patch for smach-ros that has been included in the current upstream version. Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
This commit is contained in:
parent
79ecc9267c
commit
d1c9de1a08
|
@ -1,6 +1,6 @@
|
||||||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||||
SRC_URI[md5sum] = "c5a9abf8db49abfbb05cb3ed88ef1931"
|
SRC_URI[md5sum] = "e8c39c7fe0033e7512138b9c94649c73"
|
||||||
SRC_URI[sha256sum] = "48f11db9a1be8accf6bce4dc20efa825f8fab1697d8620690eb51051ddd2c6b3"
|
SRC_URI[sha256sum] = "2f7f58064c960fc56de15fdedfd883f62122bd44874787f13c8b4d8a77c45380"
|
||||||
|
|
||||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||||
|
|
||||||
|
|
|
@ -1,36 +0,0 @@
|
||||||
From 9835342260d40cfeb4d062be1d6ddcc85c5037d8 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
|
||||||
Date: Tue, 4 Apr 2017 11:43:26 +0200
|
|
||||||
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
|
|
||||||
|
|
||||||
Upstream-Status: Submitted [https://github.com/ros/executive_smach/pull/45]
|
|
||||||
|
|
||||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
|
||||||
---
|
|
||||||
smach_ros/CMakeLists.txt | 3 ++-
|
|
||||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/smach_ros/CMakeLists.txt b/smach_ros/CMakeLists.txt
|
|
||||||
index e5694b1..f409e2e 100644
|
|
||||||
--- a/smach_ros/CMakeLists.txt
|
|
||||||
+++ b/smach_ros/CMakeLists.txt
|
|
||||||
@@ -2,7 +2,7 @@ cmake_minimum_required(VERSION 2.8.3)
|
|
||||||
|
|
||||||
project(smach_ros)
|
|
||||||
|
|
||||||
-find_package(catkin REQUIRED COMPONENTS rostest)
|
|
||||||
+find_package(catkin REQUIRED)
|
|
||||||
|
|
||||||
catkin_python_setup()
|
|
||||||
|
|
||||||
@@ -11,6 +11,7 @@ catkin_package(
|
|
||||||
)
|
|
||||||
|
|
||||||
if(CATKIN_ENABLE_TESTING)
|
|
||||||
+ find_package(rostest REQUIRED)
|
|
||||||
add_rostest(test/state_machine.test)
|
|
||||||
add_rostest(test/sequence.test)
|
|
||||||
add_rostest(test/concurrence.test)
|
|
||||||
--
|
|
||||||
2.5.5
|
|
||||||
|
|
|
@ -4,5 +4,3 @@ LICENSE = "BSD"
|
||||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=17;endline=17;md5=d566ef916e9dedc494f5f793a6690ba5"
|
LIC_FILES_CHKSUM = "file://package.xml;beginline=17;endline=17;md5=d566ef916e9dedc494f5f793a6690ba5"
|
||||||
|
|
||||||
require executive-smach.inc
|
require executive-smach.inc
|
||||||
|
|
||||||
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;striplevel=2"
|
|
Loading…
Reference in New Issue