navigation: updating to 1.11.6

The patches provided upstream are part of 1.11.6 and are removed.
This commit is contained in:
Lukas Bulwahn 2014-03-08 12:53:02 +01:00
parent 4fdfe352df
commit debf5e4c6e
23 changed files with 2 additions and 261 deletions

View File

@ -1,64 +0,0 @@
From 3d0a814884fdf638f8f8f11078113c0568e120bb Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sun, 13 Oct 2013 18:13:01 +0200
Subject: [PATCH] check for CATKIN_ENABLE_TESTING
---
base_local_planner/CMakeLists.txt | 30 ++++++++++++++++--------------
base_local_planner/package.xml | 2 +-
2 files changed, 17 insertions(+), 15 deletions(-)
diff --git a/base_local_planner/CMakeLists.txt b/base_local_planner/CMakeLists.txt
index a924092..6637ee7 100644
--- a/base_local_planner/CMakeLists.txt
+++ b/base_local_planner/CMakeLists.txt
@@ -125,17 +125,19 @@ install(DIRECTORY include/${PROJECT_NAME}/
PATTERN ".svn" EXCLUDE
)
-catkin_add_gtest(base_local_planner_utest
- test/gtest_main.cpp
- test/utest.cpp
- test/velocity_iterator_test.cpp
- test/footprint_helper_test.cpp
- test/trajectory_generator_test.cpp
- test/map_grid_test.cpp)
-target_link_libraries(base_local_planner_utest
- base_local_planner trajectory_planner_ros
- )
-
-
-catkin_add_gtest(line_iterator
- test/line_iterator_test.cpp)
+if(CATKIN_ENABLE_TESTING)
+ catkin_add_gtest(base_local_planner_utest
+ test/gtest_main.cpp
+ test/utest.cpp
+ test/velocity_iterator_test.cpp
+ test/footprint_helper_test.cpp
+ test/trajectory_generator_test.cpp
+ test/map_grid_test.cpp)
+ target_link_libraries(base_local_planner_utest
+ base_local_planner trajectory_planner_ros
+ )
+
+
+ catkin_add_gtest(line_iterator
+ test/line_iterator_test.cpp)
+endif()
diff --git a/base_local_planner/package.xml b/base_local_planner/package.xml
index d9f1de2..3420396 100644
--- a/base_local_planner/package.xml
+++ b/base_local_planner/package.xml
@@ -13,7 +13,7 @@
<license>BSD</license>
<url>http://wiki.ros.org/base_local_planner</url>
- <buildtool_depend>catkin</buildtool_depend>
+ <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
<build_depend>std_msgs</build_depend>
<build_depend>nav_msgs</build_depend>
--
1.8.1.2

View File

@ -8,5 +8,3 @@ DEPENDS = "angles costmap-2d dynamic-reconfigure geometry-msgs libeigen message-
voxel-grid visualization-msgs"
require navigation.inc
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2"

View File

@ -1,85 +0,0 @@
From 74a2a421f3802b5bddf8be794e16af9bef4ae1fc Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Mon, 14 Oct 2013 08:47:46 +0200
Subject: [PATCH] check for CATKIN_ENABLE_TESTING
---
map_server/CMakeLists.txt | 39 +++++++++++++++++++++------------------
map_server/package.xml | 2 +-
2 files changed, 22 insertions(+), 19 deletions(-)
diff --git a/map_server/CMakeLists.txt b/map_server/CMakeLists.txt
index 09bef0f..3f41a21 100644
--- a/map_server/CMakeLists.txt
+++ b/map_server/CMakeLists.txt
@@ -32,6 +32,12 @@ target_link_libraries(map_server
${catkin_LIBRARIES}
)
+add_executable(map_server-map_saver src/map_saver.cpp)
+set_target_properties(map_server-map_saver PROPERTIES OUTPUT_NAME map_saver)
+target_link_libraries(map_server-map_saver
+ ${catkin_LIBRARIES}
+ )
+
# copy test data to same place as tests are run
function(copy_test_data)
cmake_parse_arguments(PROJECT "" "" "FILES" ${ARGN})
@@ -40,26 +46,23 @@ function(copy_test_data)
endforeach()
endfunction()
-copy_test_data( FILES
- test/testmap.bmp
- test/testmap.png )
-catkin_add_gtest(${PROJECT_NAME}_utest test/utest.cpp test/test_constants.cpp)
-target_link_libraries(${PROJECT_NAME}_utest image_loader SDL SDL_image)
-
-add_executable(rtest test/rtest.cpp test/test_constants.cpp)
-target_link_libraries( rtest
- gtest
- ${catkin_LIBRARIES}
-)
-add_dependencies(rtest nav_msgs_gencpp)
+## Tests
+if(CATKIN_ENABLE_TESTING)
+ copy_test_data( FILES
+ test/testmap.bmp
+ test/testmap.png )
+ catkin_add_gtest(${PROJECT_NAME}_utest test/utest.cpp test/test_constants.cpp)
+ target_link_libraries(${PROJECT_NAME}_utest image_loader SDL SDL_image)
-add_executable(map_server-map_saver src/map_saver.cpp)
-set_target_properties(map_server-map_saver PROPERTIES OUTPUT_NAME map_saver)
-target_link_libraries(map_server-map_saver
- ${catkin_LIBRARIES}
- )
+ add_executable(rtest test/rtest.cpp test/test_constants.cpp)
+ target_link_libraries( rtest
+ gtest
+ ${catkin_LIBRARIES}
+ )
+ add_dependencies(rtest nav_msgs_gencpp)
-add_rostest(test/rtest.xml)
+ add_rostest(test/rtest.xml)
+endif()
## Install executables and/or libraries
install(TARGETS map_server-map_saver map_server image_loader
diff --git a/map_server/package.xml b/map_server/package.xml
index 2b336de..811734a 100644
--- a/map_server/package.xml
+++ b/map_server/package.xml
@@ -12,7 +12,7 @@
<url>http://wiki.ros.org/map_server</url>
<license>BSD</license>
- <buildtool_depend>catkin</buildtool_depend>
+ <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
<build_depend>roscpp</build_depend>
<build_depend>rostest</build_depend>
--
1.8.1.2

View File

@ -6,5 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=01c2bc31767cc
DEPENDS = "libsdl-image nav-msgs roscpp rostest tf yaml-cpp"
require navigation.inc
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2"

View File

@ -1,38 +0,0 @@
From be3ed623e765267ad3a64088295bdb63781c535b Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sun, 13 Oct 2013 19:52:14 +0200
Subject: [PATCH] check for CATKIN_ENABLE_TESTING
---
navfn/CMakeLists.txt | 4 +++-
navfn/package.xml | 2 +-
2 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/navfn/CMakeLists.txt b/navfn/CMakeLists.txt
index 005d7eb..2a29409 100644
--- a/navfn/CMakeLists.txt
+++ b/navfn/CMakeLists.txt
@@ -121,4 +121,6 @@ endif (NAVFN_HAVE_FLTK AND NAVFN_HAVE_NETPBM AND NOT APPLE)
# message (STATUS "pgm.h not found (optional)")
# endif (NAVFN_HAVE_NETPBM)
-add_subdirectory(test)
+if(CATKIN_ENABLE_TESTING)
+ add_subdirectory(test)
+endif()
diff --git a/navfn/package.xml b/navfn/package.xml
index bf44445..99e6589 100644
--- a/navfn/package.xml
+++ b/navfn/package.xml
@@ -13,7 +13,7 @@
<license>BSD</license>
<url>http://wiki.ros.org/navfn</url>
- <buildtool_depend>catkin</buildtool_depend>
+ <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
<build_depend>costmap_2d</build_depend>
<build_depend>geometry_msgs</build_depend>
--
1.8.1.2

View File

@ -7,5 +7,3 @@ DEPENDS = "costmap-2d geometry-msgs nav-core nav-msgs pcl-conversions pcl-ros \
pluginlib rosconsole roscpp tf visualization-msgs"
require navigation.inc
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2"

View File

@ -1,6 +1,6 @@
SRC_URI = "https://github.com/ros-planning/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "cddadf97a28ccffe93c0d662639801d5"
SRC_URI[sha256sum] = "402f1800577d22a168882aa99754d99cfd0a54e9a02a1ec804c351cd327d7540"
SRC_URI[md5sum] = "f6dd416880d0e92985be5268699d9cb8"
SRC_URI[sha256sum] = "52d88c64047539f3d7552cee48def65f082e39d37221659b2533aecef429bb42"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"

View File

@ -1,16 +0,0 @@
--- a/robot_pose_ekf/CMakeLists.txt 2014-02-26 22:23:47.631541505 +0100
+++ b/robot_pose_ekf/CMakeLists.txt 2014-02-26 22:23:58.219541227 +0100
@@ -77,6 +77,7 @@
## Tests are failing on OSX for an unknown reason
include(CMakeDetermineSystem)
if(CMAKE_SYSTEM_NAME MATCHES "Linux")
+if(CATKIN_ENABLE_TESTING)
catkin_download_test_data(download_data_ekf_test2_indexed.bag http://download.ros.org/data/robot_pose_ekf/ekf_test2_indexed.bag FILENAME test/ekf_test2.bag MD5 71addef0ed900e05b301e0b4fdca99e2)
add_executable(test_robot_pose_ekf test/test_robot_pose_ekf.cpp)
@@ -98,4 +99,5 @@
)
add_rostest(${CMAKE_CURRENT_SOURCE_DIR}/test/test_robot_pose_ekf_zero_covariance.launch)
+endif(CATKIN_ENABLE_TESTING)
endif(CMAKE_SYSTEM_NAME MATCHES "Linux")

View File

@ -6,5 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=01c2bc31767cc
DEPENDS = "roscpp bfl std-msgs geometry-msgs sensor-msgs nav-msgs tf"
require navigation.inc
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2"

View File

@ -1,46 +0,0 @@
From 72fbc995dd302f356b891fb93e9d0cdc6416cdb8 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sun, 13 Oct 2013 14:11:47 +0200
Subject: [PATCH] check for CATKIN_ENABLE_TESTING
---
voxel_grid/CMakeLists.txt | 12 +++++++-----
voxel_grid/package.xml | 2 +-
2 files changed, 8 insertions(+), 6 deletions(-)
diff --git a/voxel_grid/CMakeLists.txt b/voxel_grid/CMakeLists.txt
index d8e0f54..767dd2e 100644
--- a/voxel_grid/CMakeLists.txt
+++ b/voxel_grid/CMakeLists.txt
@@ -35,8 +35,10 @@ install(DIRECTORY include/${PROJECT_NAME}/
PATTERN ".svn" EXCLUDE
)
-catkin_add_gtest(voxel_grid_tests test/voxel_grid_tests.cpp)
-target_link_libraries(voxel_grid_tests
- voxel_grid
- ${catkin_LIBRARIES}
- )
+if(CATKIN_ENABLE_TESTING)
+ catkin_add_gtest(voxel_grid_tests test/voxel_grid_tests.cpp)
+ target_link_libraries(voxel_grid_tests
+ voxel_grid
+ ${catkin_LIBRARIES}
+ )
+endif()
diff --git a/voxel_grid/package.xml b/voxel_grid/package.xml
index 8a4ec86..459bcb3 100644
--- a/voxel_grid/package.xml
+++ b/voxel_grid/package.xml
@@ -12,7 +12,7 @@
<license>BSD</license>
<url>http://wiki.ros.org/voxel_grid</url>
- <buildtool_depend>catkin</buildtool_depend>
+ <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
<build_depend>roscpp</build_depend>
--
1.8.1.2

View File

@ -6,5 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=01c2bc31767cc
DEPENDS = "roscpp"
require navigation.inc
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2"