geometry: updating to 1.11.7
The patch provided upstream is incorporated since 1.11.4 and hence is removed.
This commit is contained in:
parent
3e776b18d8
commit
6c229309a2
|
@ -1,6 +1,6 @@
|
||||||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||||
SRC_URI[md5sum] = "f5e00ace1447819774d72be99bf09989"
|
SRC_URI[md5sum] = "5c09987b0185183d54522e92bf64d6f3"
|
||||||
SRC_URI[sha256sum] = "a32eea3dc00f80b3ba0d525e44073389a3569ae7a5250eab26ee8f0a623ffd2a"
|
SRC_URI[sha256sum] = "fbfbc707d239a76f7258372cb73a78341c0433d990d6f053340417c5ecb84231"
|
||||||
|
|
||||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||||
|
|
||||||
|
|
|
@ -1,35 +0,0 @@
|
||||||
From 18e81e33c052e26ae60259708095a2a933f75fd1 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
|
||||||
Date: Tue, 4 Feb 2014 16:02:48 +0100
|
|
||||||
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
|
|
||||||
|
|
||||||
Upstream-Status: Backport [Accepted in indigo-devel branch]
|
|
||||||
---
|
|
||||||
tf/CMakeLists.txt | 4 +++-
|
|
||||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/tf/CMakeLists.txt b/tf/CMakeLists.txt
|
|
||||||
index fa4a42f..c6988e1 100644
|
|
||||||
--- a/tf/CMakeLists.txt
|
|
||||||
+++ b/tf/CMakeLists.txt
|
|
||||||
@@ -4,7 +4,7 @@ project(tf)
|
|
||||||
find_package(catkin REQUIRED)
|
|
||||||
|
|
||||||
find_package(Boost REQUIRED thread signals)
|
|
||||||
-find_package(catkin REQUIRED angles geometry_msgs message_filters message_generation rosconsole roscpp rostest rostime sensor_msgs std_msgs tf2_ros)
|
|
||||||
+find_package(catkin REQUIRED angles geometry_msgs message_filters message_generation rosconsole roscpp rostime sensor_msgs std_msgs tf2_ros)
|
|
||||||
|
|
||||||
catkin_python_setup()
|
|
||||||
|
|
||||||
@@ -48,6 +48,8 @@ target_link_libraries(static_transform_publisher ${PROJECT_NAME})
|
|
||||||
# Tests
|
|
||||||
if(CATKIN_ENABLE_TESTING)
|
|
||||||
|
|
||||||
+find_package(rostest)
|
|
||||||
+
|
|
||||||
catkin_add_gtest(tf_unittest test/tf_unittest.cpp)
|
|
||||||
target_link_libraries(tf_unittest ${PROJECT_NAME})
|
|
||||||
|
|
||||||
--
|
|
||||||
1.8.3.2
|
|
||||||
|
|
|
@ -7,6 +7,4 @@ DEPENDS = "angles geometry-msgs message-filters sensor-msgs tf2-ros"
|
||||||
|
|
||||||
require geometry.inc
|
require geometry.inc
|
||||||
|
|
||||||
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;striplevel=2"
|
|
||||||
|
|
||||||
RDEPENDS_${PN} = "python-numpy"
|
RDEPENDS_${PN} = "python-numpy"
|
Loading…
Reference in New Issue